Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Fan stopped working! (http://www.jeepgarage.org/f203/fan-stopped-working-40085.html)

qbny94 03-31-2012 06:01 PM

Fan stopped working!
 
I just noticed that the fan under my hood behind my grille stopped working.. what could cause this and how can i fix this?

Chaoul1 03-31-2012 09:18 PM

Re: Fan stopped working!
 
Your Fuse. I forgot what fuse but it's under your bumper. Which fan stopped working? The electric fan or the mechanical one that runs off your engine.

Frango100 03-31-2012 09:28 PM

Re: Fan stopped working!
 
It all depends which fan setup you have, or the electrical fan or the hydraulic one. The hydraulic one is always running at 500 rpm with engine on and ramps up when engine temp rises.
The electrical fan should only work when the engine temp gets high or probably as well when the airco is on. There are 2 types on the electrical one, the older one with a puls modulated relay under the right headlight and the newer version with two separate relays in the power distribution center under the hood. For electrical fans the first thing to check is the fuse, probably in the PDC under the hood.
Which engine do you have and does it start overheating when standing still? Take especially care with the 4.7 that it doesn´t like to be overheated, it will warp the heads and cause the headgaskets to leak.

qbny94 03-31-2012 10:39 PM

Re: Fan stopped working!
 
im 17 and dont know too much about cars LOL i have the 4.0 L I6 its a 2000 Jeep grand cherokee laredo. Its the fan directly behind the radiator its big and black.. and is it suppose to run automatically when i start my car? on my moms trailblazer as soon as your start her engine her radiator fan starts moving

Gus9890 03-31-2012 11:16 PM

Re: Fan stopped working!
 
It sounds like it may be your fan relay, I had an issue with mine, but mine wouldn't shut off. I accessed mine via the passenger side fender-well. Pretty easy fix.

qbny94 03-31-2012 11:24 PM

Re: Fan stopped working!
 
alright but the fan is suppose to be running as soon as i start my car right?

violant00 04-01-2012 05:00 AM

Re: Fan stopped working!
 
The fan turns on when the engine reaches a certain tempurature or when the a/c gets turned on. If your fan doesn't turn on at all it may be your relay which is located under the right headlight under the bumper.

I changed the relay last week when used the jeep parked it for 2 minutes and went back to driving and noticed the temp at 240. Its a very easy job to do 30 min.

Quote:

Originally Posted by qbny94 (Post 604863)
alright but the fan is suppose to be running as soon as i start my car right?


qbny94 04-01-2012 09:57 AM

Re: Fan stopped working!
 
guys good news.. i let my car run for about 15 mins and when my engine hit a certain temp and the fan turned on.. i guess i just assumed it was suppose to be running as soon as i turn my engine on like it does on my moms truck but thanks guys glad everything is working

Gus9890 04-01-2012 11:51 PM

Re: Fan stopped working!
 
Glad to hear everything's running ok


All times are GMT -5. The time now is 11:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community