Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior/Visual (http://www.jeepgarage.org/f176/)
-   -   Putco Halogens Melted Fog (http://www.jeepgarage.org/f176/putco-halogens-melted-fog-40119.html)

FlyFlip420 04-01-2012 03:12 PM

Putco Halogens Melted Fog
 
3 Attachment(s)
Maaaaan......not a happy camper. Got these Putco Halogen bulbs a few months ago. Just noticed last night one was out, so I looked....and they melted both of the fog reflectors.

Have an email to the company I bought them from, which is also who recommended them to see what they are going to do or what the manufacturer is going to do.

Any ideas? I know this had happened on the LEDs, but hadn't read anything on the Halogens....

Scottina06 04-01-2012 03:41 PM

Re: Putco Halogens Melted Fog
 
whats the wattage? Thats probably the problem....

bmrisko 04-01-2012 04:43 PM

Re: Putco Halogens Melted Fog
 
Wattage on those Putco bulbs is like 35 or 37.5w...I think factory is 22w or so. Why should the manufacture or anyone cover bulbs that you use in a housing that was not designed to accept that high of a wattage? It is going to be even worse if you drive with them on all the time.

FWIW, new housings on Amazon are like $21.

FlyFlip420 04-01-2012 09:47 PM

Re: Putco Halogens Melted Fog
 
Quote:

Originally Posted by bmrisko (Post 605186)
Wattage on those Putco bulbs is like 35 or 37.5w...I think factory is 22w or so. Why should the manufacture or anyone cover bulbs that you use in a housing that was not designed to accept that high of a wattage? It is going to be even worse if you drive with them on all the time.

FWIW, new housings on Amazon are like $21.

Funny you say that, and you sound right.....a forum sponsor recommended them after asking for advice. Im not a light expert, and dont claim to be....which is why i asked for help from someone who sells bulbs, who should be the expert.

Bad advice is never a good thing. We will see how they handle this....

FlyFlip420 04-02-2012 12:37 PM

Re: Putco Halogens Melted Fog
 
:thumbsup:
Quote:

Originally Posted by bmrisko (Post 605186)
Wattage on those Putco bulbs is like 35 or 37.5w...I think factory is 22w or so. Why should the manufacture or anyone cover bulbs that you use in a housing that was not designed to accept that high of a wattage? It is going to be even worse if you drive with them on all the time.

FWIW, new housings on Amazon are like $21.


Do you have a link to the housings? I looked and couldn't find them....you must be a better man than I ;)

Putco, and the Xenon Depot both responded extremely FAST and siad there shouldn't have been any issues. It looks like they are going to replace the housing and the bulbs, I just need to find a place to buy the housings.

KUDOS to both Xenon Depot and Putco for such a fast response on this!! :thumbsup:

XenonDepot 04-02-2012 12:50 PM

Re: Putco Halogens Melted Fog
 
Hey, It was nice speaking with you. I'm just waiting on confirmation from Putco but am working to make sure this gets taken care of. We have sold many of these bulbs without ANY issues.

Steve

FlyFlip420 04-02-2012 02:20 PM

Re: Putco Halogens Melted Fog
 
Quote:

Originally Posted by XenonDepot (Post 605662)
Hey, It was nice speaking with you. I'm just waiting on confirmation from Putco but am working to make sure this gets taken care of. We have sold many of these bulbs without ANY issues.

Steve

Thanks Steve!

Anyone thinking of doing biz with Xenon Depot, I highly recommend them. They stand behind their products :thumbsup: and have stellar customer service. Glad that they are here on Jeep Garage!!!

It truly is an odd scenario though....

2012sleeper 04-02-2012 06:28 PM

Re: Putco Halogens Melted Fog
 
same thing happened to me, i had HIDs in there. i switched over to LEDs, i bought a pair of housings at http://www.partswebsite.com/jeepcarp...105&type=parts
there mopar parts and only $30 each

FlyFlip420 04-02-2012 07:06 PM

Re: Putco Halogens Melted Fog
 
Quote:

Originally Posted by 2012sleeper (Post 605866)
same thing happened to me, i had HIDs in there. i switched over to LEDs, i bought a pair of housings at http://www.partswebsite.com/jeepcarp...105&type=parts
there mopar parts and only $30 each


Thanks Sleeper!!! Some guys were having problems with the LEDs too....how are yours holding up?

bmrisko 04-02-2012 07:32 PM

Re: Putco Halogens Melted Fog
 
Here is a link to the housings for when it happens again...and it probably will.

http://www.amazon.com/gp/product/B00...=ATVPDKIKX0DER

This is a common problem with people on the Tahoe forum as well when they put a 37.5w bulb in a housing only designed to accept an OEM 25w or so bulb. I wish someone would make a true replacement bulb. I have tried the Putcos before and they did not snap in securely enough for me, even after modifying the tabs.

FlyFlip420 04-09-2012 10:49 PM

Re: Putco Halogens Melted Fog
 
WOW>...already got a check from Putco for the fogs :) They are supposed to be getting in touch with Xenon Depot about refunding my bulbs or getting me something different.

That was FAST and great service!!!

akimball 04-09-2012 10:54 PM

Re: Putco Halogens Melted Fog
 
:confused: jeez i ordered bulbs from them a week ago... called and they said they were on the way, called today and they said "oh sorry they are on back order". wish i knew before i ordered them....


All times are GMT -5. The time now is 10:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community