Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Electrical gremlin? (http://www.jeepgarage.org/f181/electrical-gremlin-40459.html)

CreeperJeeper 04-08-2012 07:28 PM

Electrical gremlin?
 
So last night I jumped in my 08 WK 3.7L and started it up. I noticed my EVIC trip odometer, and mileage was reset as if I had disconnected the battery. Whatever, the Jeep started and it's 2AM, time to head home. I start driving down the street and my headlights start dimming/flashing. That includes my HID headlights which are powered directly from the battery via a relay, and my halogen fogs run through the factory wiring harness. I pull over, turn it off and restart, and back to normal.

Any ideas? I figured if I shut it off and it didn't start up again, it'd probably point to an alternator issue. The Jeep has 39k miles, original battery and alternator, and I haven't seen any warning lights on the dash, nor have I run the battery down.

kennzz05 04-08-2012 10:30 PM

Re: Electrical gremlin?
 
couldnt hurt to clean the battery connections

Escape 04-11-2012 01:33 PM

Re: Electrical gremlin?
 
If it continues to act "funny" you are probably due for a new battery.

CreeperJeeper 04-15-2012 08:34 PM

Jeep wouldn't start today, no power at all, not even for the door locks. Fiddled with the power terminals which were clean, and tight, and everything was fine. Guess it was the terminals... :dunce:

Sent from my A500 using Tapatalk


All times are GMT -5. The time now is 02:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community