Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   hesitation when starting (http://www.jeepgarage.org/f181/hesitation-when-starting-40681.html)

emf14 04-13-2012 12:36 PM

hesitation when starting
 
I have a 2005 grand cherokee limited with a 4.7. My issue is when I start the engine and put my jeep into drive and start to accelerate at about 1000 rpm's the engine will hesitate for about 5 seconds. It feels like the engine is about to stall. In fact all engine noise stops. Then it comes back to life and runs fine. This only happens when I first start the engine. It has never happened when I come to a stop and then accelerate.
I replaced the TPS sensor 2 weeks ago and that did not fix the issue.
Lastly this usually happens once every few weeks. A few times it has done it twice in a day.
Any suggestions?
Thanks!

JMLoughrey 04-13-2012 11:11 PM

Re: hesitation when starting
 
year? mileage? any recent maintanence?

that might help you with us leading you down the right path.

2005JGC 04-15-2012 12:05 AM

Re: hesitation when starting
 
try cleaning your throttle body, when you do this make sure to remove the idle air control valve and clean it and the rest of the throttle body throughly.

inferno red wk 04-19-2012 09:26 PM

Re: hesitation when starting
 
I had the same issue with my jeep 4.7 limited it ended up as crazy as it sounds being dirty tranny fluid


All times are GMT -5. The time now is 02:08 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community