Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - ZJ (http://www.jeepgarage.org/f78/)
-   -   95 Laredo won't start in warm weather (http://www.jeepgarage.org/f78/95-laredo-wont-start-in-warm-weather-40686.html)

Jm6479id 04-13-2012 02:37 PM

95 Laredo won't start in warm weather
 
I've got a 95 grand Cherokee Laredo with the 4.0 inline six that is difficult to start if the weather is warm or if the engine has been running long enough to heat up. Has anyone else had or heard of this problem and have any idea what to do about it?

Frango100 04-13-2012 09:42 PM

Re: 95 Laredo won't start in warm weather
 
Difficult to start, or wonīt start at all, as the title says?
I had it with an other brand car, which didnīt want to start when hot. I really had to let it cool down for a 20 minutes or so and then it was ok. It ended up to be the engine speed sensor. On the way to the shop to get the new sensor, i got stuck in heavy traffic and the engine died at several hundred meters of the shop and didnīt want to start anymore. I got some water and poured it over the sensor, whereafter the engine started normally.Now on the jeep we have the crank sensor and the cam sensor. Try to put a cold wet cloth on one of these sensors and after a minute or so remove it and try to start. If starting ok, its most probably that sensor. If not, repeat this with the other sensor and try again.

Evan5469 04-14-2012 10:05 PM

Re: 95 Laredo won't start in warm weather
 
Could possibly be the starter. It's definitely a part that doesn't like to be hot.


All times are GMT -5. The time now is 07:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community