Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   EVIC - can't find compass VAR (variance) setting (http://www.jeepgarage.org/f203/evic-cant-find-compass-var-variance-setting-40856.html)

johnatyandoit 04-17-2012 07:33 AM

EVIC - can't find compass VAR (variance) setting
 
Just replaced the EVIC in my WJ - I read in forums that you need to set the compass variance zone. Instructions I have seen say press Reset for 5-10 sec to enter set VAR mode. I tried this on mine and nothing happens. Likewise I can't get CAL mode manually. After driving a while it went into CAL on its own, so I drove in circles until CAL disappeared and then the compass started working about right. But I have never seen a VAR mode.

Is it possible my EVIC does not support VAR setting? I have tried pushing all kinds of buttons with no success. Only other mode I get is what wjjeeps.com calls 'Compass Engineering Mode' by pressing C/T for 10 sec - this displays the raw angle (e.g. 269) along side the compass point (e.g. SW).

Can anyone shed any light on this?

Frango100 04-17-2012 10:16 AM

Re: EVIC - can't find compass VAR (variance) setting
 
To enter in VAR mode, press the C/T button and thereafter press the reset button for 10 secīs. Pressing the reset button again will let you choose between CAL and VAR. With variance on the screen,by pressing the STEP button you can change the VAR setting. When the VAR is set, just press the reset once more and voila. In which part of the States are you, or do you know which setting you need?

johnatyandoit 04-17-2012 07:18 PM

Re: EVIC - can't find compass VAR (variance) setting
 
Thanks for the reply Frank, but I tried that and no luck. Your response is about the same as other instructions I have read. For me RESET button does nothing in compass mode. The RESET button is not faulty though, because other functions (e.g. average fuel consumption) can be reset. So I'm still stuck. BTW I am in Australia and the VAR setting I need is 6.

Frango100 04-18-2012 10:11 AM

Re: EVIC - can't find compass VAR (variance) setting
 
For which reason did you change the EVIC in the first place?
I would be quite strange if your EVIC would not have the posibility to change the VAR setting or manually put it in Calibration mode if you want to.
Did you use a new EVIC, or a used one? It can be that the "new" EVIC is at fault.
Here below follows the EVIC self diagnostic check:


SELF-DIAGNOSTIC TEST
A self-diagnostic test is used to determine that the
EVIC module is operating properly, and that all PCI
data bus messages are being received for initial operation.
Initiate the self-diagnostic test as follows:
(1) With the ignition switch in the Off position,
simultaneously depress and hold the C/T button and
the Reset button.
(2) Turn the ignition switch to the On position.
(3) Continue to hold both buttons depressed until
the EVIC software version information is displayed,
then release both buttons.
(4) Following completion of these tests, the EVIC
module will display one of the following messages:
a.
Pass Self Test - Momentarily depress and
release the Reset button to return to the compass/
temperature/trip computer display mode. The EVIC
module is working properly.
b.
Failed Self Test - The EVIC module has an
internal failure. The EVIC module is faulty and must
be replaced.
c.
Not Receiving J1850 Message - The EVIC
module is not receiving proper message input
through the PCI data bus. This can result from one
or more faulty electronic modules in the vehicle, or
from a faulty PCI data bus. The use of a DRB scan
tool and the proper Diagnostic Procedures manual

are required for further diagnosis.

johnatyandoit 04-22-2012 09:44 AM

Re: EVIC - can't find compass VAR (variance) setting
 
Hi Frank,
I shelved this problem for a few days. The EVIC was replaced with a S/H one sourced from a breaker in the US. The original one had a blown display. When I first installed it, it passed the self test using the procedure as in your post, however now the self-test can't be repeated.

A further annoyance has occured. Recently the horn started beeping when I lock the car - it didn't before - and there's no option in the EVIC to turn off the horn beep. I think there might be a bit of a mismatch between the BCM and this EVIC.

I am guessing that these settings are stored in the BCM, not the EVIC itself: when I first installed it, it came up in metric units, not US.

I might try disconnecting the battery and see if that resets things. Otherwise it looks like I'll have to put up with its eccentricities.

Frango100 04-22-2012 02:19 PM

Re: EVIC - can't find compass VAR (variance) setting
 
The horn when locking/unlocking is indeed a feature for some markets. My Jeep also doesnīt have it. Its the BCM which chirps the horn, but its the EVIC which tells the BCM to do so. Strange that yours has the chirp now, but doesnīt give the option to switch it off. I never saw anything written of programming of the EVIC via a DRBIII scanner, but maybe reprogramming of the BCM would help.
Its a good idea though to try to reset it by disconnecting the battery first. Leave it disconnected for a few minutes and press the brake pedal to drain eventual charge and try again.


All times are GMT -5. The time now is 02:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community