Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Tech tip for dome light not shutting off/windows not working (http://www.jeepgarage.org/f203/tech-tip-for-dome-light-not-shutting-off-windows-not-working-40981.html)

67 Wagoneer 04-19-2012 02:54 PM

Tech tip for dome light not shutting off/windows not working
 
I searched this forum for a topic relating to this, and didn't see it. If Im too blind to see today I apologize. :p But this is something I encountered on my 2004 Overland, and apparently it's not that uncommon:

One time when I went to take off, I noticed the dome light would not shut off. Period. While trying to figure that out, I also found that my drivers front window wouldn't work either. Well as it turns out, the ground wire that goes from the window motor to ground that passes through the rubber wire guard between the door and the body was broken right in the middle of the wire guard. The factory ground wire is too stiff and is subject to breakage. This apparently will cause backfeed through the dome light assembly.

What I did is run a heavy speaker wire (and I mean a nice heavy one) in the original ground wire's place. Much more flexible, but is meaty enough to provide a solid ground. Problem solved-lights go out and window works. :thumbsup:

Frango100 04-19-2012 07:38 PM

Re: Tech tip for dome light not shutting off/windows not working
 
Sorry, your just too blind to see it:slapfight::lol:
It was discussed several times, but its never too much when its related to our beloving Jeeps. Maybe someone who is searching for it can use it.

67 Wagoneer 04-20-2012 10:16 AM

Re: Tech tip for dome light not shutting off/windows not working
 
Quote:

Originally Posted by Frango100 (Post 615997)
Sorry, your just too blind to see it:slapfight::lol:
It was discussed several times, but its never too much when its related to our beloving Jeeps. Maybe someone who is searching for it can use it.

:lol: I had a feeling it might have been discussed before, as it is a fairly common issue. But if my millionth repost of it helps one Jeeper it'll be worth it. :thumbsup:


All times are GMT -5. The time now is 05:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community