Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Malfunction indicator light on- only 300 miles (http://www.jeepgarage.org/f107/malfunction-indicator-light-on-only-300-miles-41415.html)

JeepMonster 04-29-2012 09:56 AM

Malfunction indicator light on- only 300 miles
 
Turned on the Jeep this morning and the MIL was illuminated. Not sure what to do since the dealer is closed. Checked the oil filter cap and others that I could see.

77Cherokee 04-29-2012 10:18 AM

Re: Malfunction indicator light on- only 300 miles
 
If it doesn't happen again then it was probably just a glitch. If it does, I would take it in and let them scan it.

JeepMonster 04-29-2012 10:26 AM

Re: Malfunction indicator light on- only 300 miles
 
I tried turning it off and on a few times but it's still on. I'm going to go to Advance Auto parts to have them read the code since the dealer is closed.

Quote:

Originally Posted by 77Cherokee (Post 621137)
If it doesn't happen again then it was probably just a glitch. If it does, I would take it in and let them scan it.


JeepMonster 04-29-2012 11:06 AM

Re: Malfunction indicator light on- only 300 miles
 
Evaporative emission system leak detected (very small leak)


I cleared the code- going to see if it comes back on and call the dealer when they open tomorrow

Any ideas what would cause this with only 300 miles on the car? My only guess is a bad gas cap.

mr_bots 04-29-2012 12:44 PM

Re: Malfunction indicator light on- only 300 miles
 
Might be somewhere else in the system, the evap system runs from most of the length of the vehicle so plenty of room for leaks. Maybe its loose or cracked up where it ties into the intake? I believe these have a check gas cap icon in the EVIC if it thinks the leak is the gas cap.

BobsWK2 04-29-2012 06:14 PM

Re: Malfunction indicator light on- only 300 miles
 
Quote:

Originally Posted by jeepmonster (Post 621167)
Evaporative emission system leak detected (very small leak)


I cleared the code- going to see if it comes back on and call the dealer when they open tomorrow

Any ideas what would cause this with only 300 miles on the car? My only guess is a bad gas cap.


R&R and tighten the gas cap till it clicks. It still may take up to 50 miles for the MIL to remain off.

JeepMonster 04-29-2012 06:41 PM

Re: Malfunction indicator light on- only 300 miles
 
Yeah I did tighten it until it clicked a couple times before the light came on. After the light came on this morning I reset cleared the code and retightened the gas cap.

JeepMonster 04-30-2012 05:43 AM

Re: Malfunction indicator light on- only 300 miles
 
When you guys turn on your vehicle how long does the MIL illuminate before it goes away?

JeepMonster 05-01-2012 06:44 AM

Re: Malfunction indicator light on- only 300 miles
 
My light comes up for like a second, just want to make sure I didn't clear the code for the MIL check out of the computer.

JeepMonster 05-05-2012 01:45 PM

Re: Malfunction indicator light on- only 300 miles
 
The light came back on today and is staying solid. The dealer said to bring it by Monday as he thinks it's something with the computer and they are closed tomorrow. I don't get why it came on again, that's twice in 500 miles.

JeepMonster 05-07-2012 06:36 AM

Re: Malfunction indicator light on- only 300 miles
 
Heading to the dealer this afternoon to see what's wrong. I noticed that when the light is on though the remote start or Eco mode don't work.

ajs800 05-07-2012 08:08 AM

Re: Malfunction indicator light on- only 300 miles
 
mine popped on and off during a 4wk span but has now been off for the past 5wks. Never did take it in as it was running fine. I plan to have it scanned once it goes for its first visit to the dealer.


All times are GMT -5. The time now is 02:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community