Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   2007 4.7 GC 4x2 Laredo has a cough (http://www.jeepgarage.org/f77/2007-4-7-gc-4x2-laredo-has-a-cough-41849.html)

wkcherokee 05-07-2012 10:08 PM

2007 4.7 GC 4x2 Laredo has a cough
 
We just purchased this a week ago. Trying to diagnose the issue. I work at the dealership that we bought it from so work is being taken care of, but I want to know you guy's input. The check engine light is on.

Video of the exhaust. Ignore the little girl but the sound i keep hearing is right after it.

http://videobam.com/TPief

And video of the rpms when this sound happens.

http://videobam.com/LDiJw

What I am worried about is that it is an injector. The code is going to be read tomorrow so I will know more then.

Btw first post but certainly not my first time here! Keep doing what you're doing guys, Jeep brother for life!

wkcherokee 05-07-2012 10:15 PM

Also, it stutters slightly when cruising, no matter the speed.

wkcherokee 05-07-2012 10:51 PM

And yes i do realize its upside down. Recording, uploading, and sharing done on iPhone.

wkcherokee 05-08-2012 08:39 PM

Ok so cyl. 1 misfire. Blew out the plug and reset to see if it was just water causing it to short. Still feel and hear the stuttering. No light yet after 70 miles since disconnecting battery. I think i need new plugs or a new coil. Any thoughts?

2005JGC 05-09-2012 01:03 AM

Re: 2007 4.7 GC 4x2 Laredo has a cough
 
The last couple 4.7's I have had apart it was head gasket failure around the front cylinders.

Before you go replacing anything, swap the #1 coil for another cylinder, do the sparkplug too, but change that to a DIFFERENT cylinder so you will have your coil and your plug on different cylinders. From there drive it and see if the code that sets follows. It did look like your idle was fluctuating a little and the TPS is a very common problem on the 4.7l that will cause an idle fluctuation.

wkcherokee 05-11-2012 06:47 PM

Figured out it was the spark plug. Fixed. Now just have to get the squeel from the back left brake fixed and get some mats and shes done!


All times are GMT -5. The time now is 04:37 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community