Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Trans Over Temp msg displayed (http://www.jeepgarage.org/f181/trans-over-temp-msg-displayed-42452.html)

Roach333 05-22-2012 06:59 PM

Trans Over Temp msg displayed
 
2006 JGC 4.7l. I recently took the jeep in too have the EVAP system checked/fixed because I needed to get the car smogged. I figured while the car was there I'd get the exhaust leak fixed at the same time.

Initially, I had codes P0455 and P0456 and the check gas cap message displayed. The mechanic ran a smoke test and changed a hose and the purge valve (plus new exhaust bolts and gaskets, but that's unrelated to my current problem).

Now initially the mechanic said he was hesitant to change the EGR valve as he's rarely seen those go but but thought it was leaking.

Here's where it gets weird. Immediately after picking up the jeep and driving it started having idle issues on start up. The idle would fluctuate while sitting in park. I then went and got an oil change because the smog station was in another state. Immediately after the oil change I'm driving at low speeds and the message trans over temp comes on!

I pulled over, turned off the car, and restarted it. I figured I was going to jump on the freeway and see if the message came back on; it didn't and I drove 300 miles round trip. Later that evening I was heading somewhere and the trans over temp message came back. !!!!!!! Yesterday my check gas cap msg comes back on and today the check engine light is back with P0457.

Is there any way these issues are all related or is the jeep possessed? I really dont think I should be having all these issues with only 70,000 miles.

Any help appreciated.

2005JGC 05-22-2012 10:09 PM

Re: Trans Over Temp msg displayed
 
Typically when I see evap leaks on the WK platform its not actually a leak, its the esim switch on the charcoal canister. It is this switch that tells the pcm if there is a leak or not. Typically its just a false failure by a failing esim switch. I dont think I have EVER replaced an purge solenoid on a WK (not that they dont ever fail). I rarely use smoke when testing newer systems, most I go straight to the pressure test, seems like 9 times out of 10 there is no leak indicating a bad esim switch or something like the cap was loose.

EGR valves on the 4.7 are not as common as the hemi but they do fail.

Also a VERY common cause for idle fluctuation on the 4.7l is the throttle position sensor.

Trans temp, due to your symptoms (when it was coming on) It sounds like an erronious message. likely a circuit failure or sensor failure... the temperature sensor is in the transmission range sensor, the valve body must be removed to replace it.... I have seen this failure before.

Roach333 05-23-2012 11:43 AM

Re: Trans Over Temp msg displayed
 
Thanks for the info. I paid $$ to get everything fixed so I'll relay the information to the mechanic when I take it in next week. I'm almost convinced the trans over temp is a faulty message because it's just too coincidental.

It's like the idle. I never had any issues with it, but it could have been due to the EVAP leak or the exhaust leak. One things for sure, it's not actually a loose gas cap.

Thanks again.

huskyenergy91 08-17-2012 05:15 PM

Re: Trans Over Temp msg displayed
 
Bump...ever figure out what this message was?

Im getting the same message, and I get it almost every day


All times are GMT -5. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community