Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Limp mode (http://www.jeepgarage.org/f181/limp-mode-42769.html)

jeremyc653 05-31-2012 06:35 AM

Limp mode
 
Hey everyone We just recently bought a 2005 jeep wk my issues are sometimes when driving the rpms will go to 4k and the jeep will only drive up to 20 mph. any ideas on what might be causing this?

jeremyc653 05-31-2012 06:49 AM

Re: Limp mode
 
kind of feels like it has no power

WK HEMInKY 05-31-2012 10:31 AM

Re: Limp mode
 
When my jeep went into limp mode I was on the expressway and It wa stuck in 3rd gear, I was merging and all the sudden i felt it downshift real hard and the normal "D" for drive was a 3 and I could not get out of the gear. Sounds like you are expieriencing the same issue I had but a different solenoid in your transmission went out. All in all I had a solenoid go bad in my tranny, not the end of the world if it is just a single one and I'd also advise that you go ahead and do a transmission service(fluids, filters and seals)

CPT2010 05-31-2012 11:05 AM

Re: Limp mode
 
it could be a few things.

Mine did that...

Problem was a bad cell in the battery. It would make the jeep stay in 4th and act funny like you said about the rpms.

A lot of batterys die when the first strong waves of heat start to come through for summer.

A little tip. your battery might read good like mine did. So being the battery was under warranty, i took my battery out and brought to walmart and told them it was bad and got a free replacement without any hassle.

I hope this helps.

garllo 05-31-2012 12:27 PM

Re: Limp mode
 
Another cause could be the notorious shift bezel assembly. Very common problem and the jeep will act as yours has. Search the forum and you will gain alot of info on this. There is also a pretty good how to- pertaining to disassembling and cleaning the unit. You don't want to run off and buy a new one first shot because they run around $600. Pull the codes and that should narrow it down! Best of luck.

Escape 05-31-2012 01:50 PM

Re: Limp mode
 
Pull the codes before you disconnect the battery.

If it went into limp mode then there should be codes. It will help you narrow down the cause.

Post those up. It could be many different things.

When it does the limp mode crap in an '05 just shift it into neutral and restart..then place it back into drive. This can be done while moving in an 05, not sure on other years.

JMLoughrey 05-31-2012 10:54 PM

Re: Limp mode
 
can be done on an 07 as well.

jeremyc653 06-01-2012 06:44 AM

Re: Limp mode
 
first off thanks everyone. When it goes it to this mode it only last for 30 sec and then works fine there is no cel so idk if there are codes to pull.

JMLoughrey 06-01-2012 02:25 PM

Re: Limp mode
 
Odd, when mine went into limp mode it blew a mass amount of codes.

jeremyc653 06-02-2012 06:44 AM

Re: Limp mode
 
Quote:

Originally Posted by JMLoughrey (Post 637557)
Odd, when mine went into limp mode it blew a mass amount of codes.

if it is showing codes it would only be while it was doing it. my wife drives it 99% of the time it happened only one time to me and i didn't notice cel


All times are GMT -5. The time now is 07:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community