Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   'service 4wd' light, again! (http://www.jeepgarage.org/f107/service-4wd-light-again-42794.html)

rich mac 05-31-2012 09:04 PM

'service 4wd' light, again!
 
After a few months of ownership, I started having the 'service 4wd' light blink on for a few seconds at random times. The dealer flashed the TSB concerning the problem and it went away. A few weeks ago the light started coming on again, concurrently with the 'traction control off' light. Happened only while braking and after many miles of highway speed driving. Dealer diagnosed a problem as the transfer case shift motor. He said Jeep must be having a problem with them because replacements were on national back order (might take a month or more to get one). He said that I can keep driving it without any harm, and it shifts in and out of 4 wheel low just fine.
Anyone else having problems in this area, or other back ordered parts?

rubicontrail.net 05-31-2012 10:27 PM

Re: 'service 4wd' light, again!
 
Faulty wheel position sensors or brake switch can also cause these symptons.

rich mac 06-01-2012 10:22 PM

Re: 'service 4wd' light, again!
 
Quote:

Originally Posted by rubicontrail.net (Post 637294)
Faulty wheel position sensors or brake switch can also cause these symptons.

Thanks, I'll mention this to my service writer if the problem persists. I have an excellent dealer who seems to be interested in getting things right.

rich mac 06-14-2012 08:40 AM

Re: 'service 4wd' light, again!
 
Update - dealer replaced the transfer case shift motor and a control module (both were on back order for a time), said it test drove fine. When I started home the same problem happened within two blocks. Took it back and explained to the service dept the problem was not solved. They said they'd look into it. They let me keep the loaner, which I appreciate since technically they don't have to. I kinda felt sorry for them. I am wondering, since the parts they replaced obviously weren't the problem, do they get reimbursed for them?

JRNYC 06-14-2012 12:40 PM

Re: 'service 4wd' light, again!
 
Yes they are paid for the service. The respond to a TSB which has your symptons. The Sheet they look on gives them instructions like test drive the vehicle for 10 minutes,, if noise is heard replace ABC. Yes they get reimbursed/paid

SixZeroFour 07-16-2012 11:59 PM

Re: 'service 4wd' light, again!
 
Hey rich mac, any updates? My Jeep is going through the identicle scenario at the dealer. Thnx

rich mac 07-17-2012 07:40 PM

Re: 'service 4wd' light, again!
 
Dealer called me the next day, said they found a wire loose. They said they test drove it five times this time to make sure it was fixed. Sure enough, the problem went away.

T&TJGC 02-09-2013 04:06 PM

Re: 'service 4wd' light, again!
 
Thanks for posting this... having the same exact problem with our '13 Hemi Grand Cherokee Overland (2500 miles). Went in last Tuesday and the dealer flashed the computer- the next day the service 4wd light came on 16 separate times during a 22 mile commute to work. Took it back to the dealer yesterday and this time it flashed a code that the transfer case motor was bad. It's on order and should be in next week- hopefully this will fix our problem as well!

smesx 09-26-2013 09:24 AM

Re: 'service 4wd' light, again!
 
Hate to necro-bump but this thread was helpful as I was having the same issue.

Was having the "serv 4wd" message intermittently. Had the dealer do the TSB flash and a couple other things that didn't fix the problem. After a 4th visit they were finally able to pull the code for a bad transfer case motor and replaced it the next morning. I'm on day 2 with no issues. Hope this helps someone else.


All times are GMT -5. The time now is 04:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community