Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Ac not cooling (http://www.jeepgarage.org/f107/ac-not-cooling-42909.html)

Margo 06-03-2012 06:33 PM

Ac not cooling
 
I have an issue with the AC on my 2011 GC Limited. Short trips or just around town no issues but when the trip is longer than 2 hrs the AC stops cooling. The fan is blowing b/c it is making noise but no air is coming from the vents. I have had the dealership check it 3 times and no problems are found. The report it is perfect and cooling. And of course when I arrive home from the longer trips it is usually Sunday or late. Has anyone else had this issue? Thanks Margo

IndyBob 06-04-2012 04:07 AM

Re: Ac not cooling
 
Quote:

Originally Posted by Margo (Post 638392)
I have an issue with the AC on my 2011 GC Limited. Short trips or just around town no issues but when the trip is longer than 2 hrs the AC stops cooling. The fan is blowing b/c it is making noise but no air is coming from the vents. I have had the dealership check it 3 times and no problems are found. The report it is perfect and cooling. And of course when I arrive home from the longer trips it is usually Sunday or late. Has anyone else had this issue? Thanks Margo

It sounds like it is freezing up because of low refrigerant on those long trips. Next time it does this make sure you are not in Auto mode and switch off the AC button but leave the fan on. After awhile the air should start flowing from the vents. You can then turn the AC back on and it should start to cool.

If this happens then you are low on refrigerant.

Seems like a dealer service department could figure this out.

hammer1234 06-04-2012 10:52 AM

Re: Ac not cooling
 
Maybe it's time to go to another service department...when I had AC issues (noise, not cooling) and one dealer just checked it and said it was OK while the second dealer actually checked the refrigerant level and found a leak.

rustyosaurus 06-04-2012 02:05 PM

Re: Ac not cooling
 
had the same exact issue just yesterday!!! drove from denver to kansas city - a 9 hour car ride. half way home we noticed that it was getting hot and air didn't seem to be coming out of the vents. it had been on auto on 72 degrees. turned off auto and turned up the fan to the highest setting. it did feel like cool (but maybe not cold?) air was coming out but it was coming out at a lower setting than LOW even though it was on the highest setting. you could hear the blower at the highest fan setting but hardly anything came out. turned the air down to 67 because by this time it was stifling in the car. no go. turned it off for 20-30 minutes and it seemed to work fine the last 2 hours of the trip.

i even turned off the AC button hoping that at least outside air would blow though but nothing - nothing would come through. was very frustrating.

this actually happened to me another time during the weekend when i drove from denver to aspen - 4 hour car ride. i couldn't figure out why it wasn't cool in the car anymore as no air seemed to be coming out of the vents. same thing.

i will take it in to get looked at but i know they are going to try and operate it and say it works fine.

please let me know if you figure out the issue.

justin1569 06-10-2012 07:34 AM

Re: Ac not cooling
 
Exact same thing happened to me. Any fixes?

rustyosaurus 06-10-2012 12:14 PM

Re: Ac not cooling
 
taking it in tomorrow morning will let you know. when i made the appointment the service guy was quick to say - oh, it's freezing up. so maybe they'll be able to fix it.

kennzz05 06-10-2012 03:35 PM

Re: Ac not cooling
 
they should be looking into replacing the low pressure switch also. This is the switch that is supposed to turn off the compressor when the operating pressures get close to the point where icing would occur.

rustyosaurus 06-11-2012 01:27 PM

Re: Ac not cooling
 
I'm so annoyed! Just got the call from the dealer and of course they said they found no codes, nothing wrong, no issues at all. Said the low pressure switch was functioning correctly. He told me that what was happening was normal and the direction he got from Chrysler was that when it happens, to turn on the recirculation button and possibly even turn the temperature up. I told him that I had it on 73 when it happened and he kept saying this is normal in a high humidity situation. I responded with - I was in Colorado when it happened.

Anyway - he had nothing to tell me and said this was the direction they were given from Chrysler about the issue and that everyone else who had the problem had it fixed when they turned on the recirculation button.

He said we should all be driving with the recirculation button on all the time. Whatever - I'm pissed.

Does this sound right to you?

UPDATE: i called back and talked to a different service rep who just re-read the notes and said all the same things. i called back because i wanted to make sure they checked for leaks and checked the freon level. he assured me they checked for "everything". I called and made an appt at another dealer. we'll see what happens. what was funny was when i described the issue the guy at the second dealer didn't say much until i told him it was a 2012 JGC and then he was really surprised. he said it did not sound normal.

jvandy50 08-20-2012 08:06 AM

Re: Ac not cooling
 
Anybody get any decent info from dealer on this issue? My wife and I had this happen Friday on just an hour ride. Noticed it was hot, but fan was set high enough we shoulda felt air. Kept sticking my hands up there and could barely feel anything and fan was on 4th or 5th level. Could turn it off and back on and it would blow cold for a bit, then stop blowing as much air, and the GC would get warm on the inside with the freaking temp set on low and fan on level 4-5

KevinPatty 08-23-2012 09:19 PM

Re: Ac not cooling
 
I just had this happen on a 5-hour drive in low humidity, and moderate temps (mid 80s). We tried changing temps, switching from fresh to recirculating, changing vents, and nothing worked. We turned the system off and after about 30-45 minutes it worked again. I took it to the dealership today and they said everything is working as designed and there are no problems. Has anyone figured out a solution yet? Thanks!

MOCON4TN 09-02-2012 06:09 PM

Re: Ac not cooling
 
I actually joined this forum to see if there was anthing listed on the climate control problem. I have a 2011. On two occasions it has seemed that the ac quit working. Both were high humidity situations. I turned down the temp setting and I could hear the fan blowing but nothing flowed out of the vents. First time I took to the delaer and they reported it was working fine. The second time was today. I turned the ac off and it was working "normal" again by the time I got home (30 minutes or so). What gives???

jason.jeep 09-10-2012 08:33 PM

Re: Ac not cooling
 
I've experienced the same thing a few times. Has anyone had any luck getting to the root cause?


All times are GMT -5. The time now is 12:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community