Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Problem with Quadra Lift (http://www.jeepgarage.org/f107/problem-with-quadra-lift-43205.html)

Boba10320 06-10-2012 06:22 PM

Problem with Quadra Lift
 
I am having a problem with the quadra lift. It seems to work fine when going back and form from sport mode. However when I try to use it for any of the raised settings, the little yellow indicator will blink on the switch but the vehicle does not raise up. Have tried it with engine running in park. Have tried it with vehicle slowly moving. Never raises up. If I put it into sport mode it will lower just fine. And if I take it out of sport mode it will raise up just fine. Am I doing something wrong or is there a problem? Would appreciate any help....

BobsWK2 06-10-2012 08:03 PM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by Boba10320 (Post 641590)
I am having a problem with the quadra lift. It seems to work fine when going back and form from sport mode. However when I try to use it for any of the raised settings, the little yellow indicator will blink on the switch but the vehicle does not raise up. Have tried it with engine running in park. Have tried it with vehicle slowly moving. Never raises up. If I put it into sport mode it will lower just fine. And if I take it out of sport mode it will raise up just fine. Am I doing something wrong or is there a problem? Would appreciate any help....


Just checking. All doors are closed with engine running and in park?

chibianh 06-10-2012 08:27 PM

Re: Problem with Quadra Lift
 
have it checked out by your dealer. similar symptoms on mine a while back.. ended up getting the compressor replaced.

cbowen 06-10-2012 10:53 PM

Re: Problem with Quadra Lift
 
Mine is doing the same thing. I just have not had time to take it to the dealer. I was afraid this was going to fail when I purchased the vehicle. I hope they get it all figured out and it is not an on going problem.

jp467 06-10-2012 11:37 PM

Re: Problem with Quadra Lift
 
Its most likely going to be a failed compressor.

Boba10320 06-11-2012 07:53 AM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by BobsWK2 (Post 641626)
Just checking. All doors are closed with engine running and in park?

Yes....doors closed and in park.

Boba10320 06-11-2012 07:55 AM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by jp467 (Post 641719)
Its most likely going to be a failed compressor.

I was thinking that might be it. Seems like I hear a lot from the air tank lately....used to be I would not hear it at all. Now I hear the noise it makes all the time.

Boba10320 06-11-2012 07:56 AM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by cbowen (Post 641701)
Mine is doing the same thing. I just have not had time to take it to the dealer. I was afraid this was going to fail when I purchased the vehicle. I hope they get it all figured out and it is not an on going problem.

This was my concern in purchasing the Overland...figured the quadra lift might be a problem. Now it is after 4800 miles :(

bromhead 06-11-2012 09:06 PM

Re: Problem with Quadra Lift
 
They never could fix my problem with the QL. I wouldn't purchase another vehicle with it

jp467 06-11-2012 09:25 PM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by Boba10320 (Post 641782)
I was thinking that might be it. Seems like I hear a lot from the air tank lately....used to be I would not hear it at all. Now I hear the noise it makes all the time.


It might be a leak if you are hearing alot from the air tank. If it won't raise above normal ride its usually a bad compressor and in some cases its a leak. Sometimes if you have a leak it leads to a bad compressor because it will run all the time.

Boba10320 06-12-2012 03:54 PM

Re: Problem with Quadra Lift
 
Quote:

Originally Posted by Boba10320 (Post 641590)
I am having a problem with the quadra lift. It seems to work fine when going back and form from sport mode. However when I try to use it for any of the raised settings, the little yellow indicator will blink on the switch but the vehicle does not raise up. Have tried it with engine running in park. Have tried it with vehicle slowly moving. Never raises up. If I put it into sport mode it will lower just fine. And if I take it out of sport mode it will raise up just fine. Am I doing something wrong or is there a problem? Would appreciate any help....

Starting to get a little concerned....had it in the dealer and they really have no idea what is wrong or the solution. Was told that last one that came in with a quadra lift issue took 6 days to fix.

Boba10320 07-03-2012 08:35 PM

Re: Problem with Quadra Lift
 
Well the second dealer got the problem fixed in 90 minutes.....filled the tank with nitrogen and reloaded the software and all appears to work great now.


All times are GMT -5. The time now is 01:43 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community