Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   01 auto 4.0 - CEL after fill-up? (http://www.jeepgarage.org/f203/01-auto-4-0-cel-after-fill-up-43334.html)

sergioad89 06-14-2012 09:12 AM

01 auto 4.0 - CEL after fill-up?
 
I'm not an expert or mechanic, but I think I know most terms by now because I've had this problem for a while now...

Here is the brief: Sunday I filled up the tank, and ti ran fine for 55 miles, after which it sat for 5 hours, and then turned on, and it REV'd up to ~3.5k before wanting to shift (i had to play with pedal & no CEL yet).

Then I parked it somewhere, adjusted the kick down cable, turned it back on which it now had the CEL on. It wouldn't rev up to 3000 anymore, but it wouldn't rev up to the regular 2k rpm before shifting to 2nd (hard acceleration/hesitation/low speed from stop/red light). All other gears seemed fine.

This morning, I drive 0.2 miles to the gas station, put 3 gallons in, and the car goes back to the ~3.5k rev before "wanting" to shift. It was fine after it shifted to 2nd and beyond.

And so I'm more leaning to believe that it only happens every time I open my gas tank door and stick it in (as wrong as that may sound)... Car is parked as I'm at work now, so I will update when I leave for home.

Any ideas on what it could be? I got the governor sensor/solenoid replaced.

Spark Plugs? MAF? TPS? O2 Sensor? Fuel Filter? :confused:

Scottina06 06-14-2012 09:35 AM

Re: 01 auto 4.0 - CEL after fill-up?
 
pull the code

sergioad89 06-14-2012 10:36 AM

Re: 01 auto 4.0 - CEL after fill-up?
 
Last 2 times I pulled code, it was P1757 and P1762/3 codes.

I'll check codes today when I get home, but what if they are those 2 codes again?

Frango100 06-14-2012 11:16 AM

Re: 01 auto 4.0 - CEL after fill-up?
 
Yes, pulling the codes is the first step to see what is wrong. Where the governor pressure sensor/solenoid replaced for the same symptoms you have now?
If you get all 3 codes back again, then have a look at the fuses 5 (30A) and 28 (15A) in the Power Distribution Center and swap the transmission control relay with auto shutdown relay.

sergioad89 06-14-2012 11:33 AM

Re: 01 auto 4.0 - CEL after fill-up?
 
Quote:

Originally Posted by Frango100 (Post 643207)
Yes, pulling the codes is the first step to see what is wrong. Where the governor pressure sensor/solenoid replaced for the same symptoms you have now?
If you get all 3 codes back again, then have a look at the fuses 5 (30A) and 28 (15A) in the Power Distribution Center and swap the transmission control relay with auto shutdown relay.

The first time, mechanic cleaned some plug/cable that went from transmission to somewhere (engine?), and after that the car ran like before.

Second time, same symptoms, he replaced the cable from junker, and put in sensor/solenoid.

Third time, to be continued...

Frango100 06-14-2012 12:02 PM

Re: 01 auto 4.0 - CEL after fill-up?
 
Ok, let us know the codes first. i presume that you know that you can pull the codes yourself using the key dance: ignition switch off/on 3 times and leave it in on after the third time, the odometer will show the fault codes one by one or DONE when no faults set. I presume that the fault where cleared from the memory after the repair was done?
The gov pressure sensor and solenoid where no junkyard parts i presume?

sergioad89 06-14-2012 09:56 PM

Re: 01 auto 4.0 - CEL after fill-up?
 
The code shows up in odometer... P1762. Only one this time...

Gov. and Solenoid were from junker. :(

sergioad89 06-15-2012 08:30 AM

Re: 01 auto 4.0 - CEL after fill-up?
 
Update:

Last night, the CEL went off, and the car ran like before... great shifting, great speed, great acceleration..

However, when doing the key dance, it still shows P 1762.

Why is that?

Frango100 06-15-2012 03:02 PM

Re: 01 auto 4.0 - CEL after fill-up?
 
Most DTC's only go away after several key cycles (and no fault). You could reset the fault with a scanner or just disconnect the battery for some minutes.
If the code returns and the shifting misbehaves itself again, its probably time for a NEW gov press sensor/solenoid.
Buying this from a junkyard you will never know what you get.


All times are GMT -5. The time now is 06:25 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community