Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   have you replaced your waterpump??? (http://www.jeepgarage.org/f77/have-you-replaced-your-waterpump-4339.html)

spiker01 11-27-2009 11:41 PM

have you replaced your waterpump???
 
i was having an issue with a clacking sound from under the hood, so upon further inspection i noticed my water pump was failing. i only have 53000kms on my jeep so i was pretty surprised it was messed up so soon. the older wj's and xj's water pumps wore out prematurely at 130000kms, but 50,000?? damn. anyway i took it to the shop as i am too busy, and the garage is too full to do it myself. $550 dollars later and im all fixed. definately pricey, but what ya gonna do?? so.......has anyone elses replaced their waterpumps so soon??? BTW i think in miles its only like 28000

1 GRAND 11-28-2009 01:50 PM

Re: have you replaced your waterpump???
 
Nope. 43,500 on the Overland and over 300,000 on the old ZJ and no problems.

Hemi WK 11-28-2009 01:57 PM

Re: have you replaced your waterpump???
 
Wow that sucks. What engine do you have? I'm at 57K miles and no problems. My old 4.7 WJ had close to 190K miles on it when I sold it and the water pump was still original.

DJ BoNiOmArIo 11-28-2009 03:33 PM

Re: have you replaced your waterpump???
 
one of my friends had to replace the water pump on his wj when it had only 15k miles on it ...

I guess ur water pump was a lemon like his ... chit like that happens hope there is nothing else that is wrong

TimmyB 11-28-2009 04:21 PM

Re: have you replaced your waterpump???
 
I had a 94 GC where the water pump went on it at about 110,000 miles, the shop charged me $330 to replace it, then it went again about 30,000 miles later and I picked one up myself and installed it for about $115.

You never know with engine parts like that, could of been a bad seal or something not machined right from the manufacturer. Things like water pumps are common to replace as its always spinning. The price of over $500 you spent was def very high. The water pumps on a WK are fairly easy to get to and replace yourself, if one has the time and tools to do it.

TimmyB 11-28-2009 04:23 PM

Re: have you replaced your waterpump???
 
But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?

1 GRAND 11-28-2009 07:26 PM

Re: have you replaced your waterpump???
 
Quote:

Originally Posted by TimmyB (Post 107631)
But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?


You can hear the bearings going out of a waterpump.

spiker01 11-28-2009 08:36 PM

Re: have you replaced your waterpump???
 
yes it was the bearings. you could move the shaft a 1/4", it was leaking but barely. i would have done it my self, but i have been on a tight schedual lately. im just glad its all fixed. oh ya, i have the 3.7l. the jeep has been great really. i have replaced the battery, and waterpump....thats it. it runs and drives great

Chaoul1 11-28-2009 09:03 PM

Re: have you replaced your waterpump???
 
My ZJ's water pump went out 2 months before summer and it had 206,000 miles on it and that was the original water pump.

Hamze 11-28-2009 11:04 PM

Re: have you replaced your waterpump???
 
The Quality of modern vehicles is deteriorating guys.... Not as good as the old ones... have the 3.7L , replaced pump at 50,000 miles, and the 4 O2 sensors ..

TimmyB 11-29-2009 03:08 AM

Re: have you replaced your waterpump???
 
I have done the water pump in my WK this summer when it had about 60k on it. I also replaced the belt because I got a new one cheap on ebay. My water pump was leaking coolant, and I replaced the big upper coolant hose to the radiator and all the clamps just for fun.

mmason3838 10-05-2011 04:18 PM

Re: have you replaced your waterpump???
 
Quote:

Originally Posted by TimmyB (Post 107631)
But you say you had a "clacking" sound under the hood, and it was in fact the water pump? Usually when a water pump fails the coolant pisses out of it. Was it over heating also, or any leaking coolant?


I have the same problem currently with my water pump, the clacking is definetly coming from the pump


All times are GMT -5. The time now is 05:19 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community