Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   cooling problem (http://www.jeepgarage.org/f203/cooling-problem-43545.html)

kidfixit27 06-19-2012 01:21 AM

cooling problem
 
hi everyone, my problem started when my 00 wj 4.0l started overheating at stop lights and slow traffic , but would cool back down at high way speeds, i researched the problem and found out my electric fan was not operating. I replaced the fan relay and it started working again. Afew days later i was driving to work on a 90 degree day at highway speeds and i noticed my temp gauge started climbing again, once i slowed down and got into town my temp droped. once i got parked at work i took a look under the hood at my mechanical clutch fan (wich my wj came with both) and i was able to stop it with my hand with ease at a idle, i reved the motor up and it still spun at a very slow speed. The electric fan seem to keep the motor at the 3/4 mark or just above which to me seems hot because it use to run at 210. i assume i have to replace my clutch fan ... any other possible ideas , any help given would be appreciated since this is my daily driver

kidfixit27 06-19-2012 12:57 PM

Re: cooling problem
 
Well i decided to go ahead and replace the water pump,thermostat, and fan clutch

hoffmanestates 06-19-2012 08:20 PM

NEVER grab a fan blade when motor is running... you never know when it just might grab..

Turbo charged G2X using tapatalk 2


All times are GMT -5. The time now is 12:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community