Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   PCM problem (http://www.jeepgarage.org/f203/pcm-problem-43676.html)

JeepFreak12 06-21-2012 11:52 AM

PCM problem
 
My 99 4.7 randomly shuts off on warm days. I took it to the dealership and they said the pcm is getting hot and loosing connection. I just replaced the pcm a little over a year ago. Any one else have this problem? And when it shuts off i get the light on the dash of the key with a line thru it. Any help is much appreciated.

01grand 06-21-2012 02:33 PM

Re: PCM problem
 
Sounds like its randomly getting a signal from the SKIM module that the key in the ignition doesn't have the right chip in it. Could be a bad SKIM module, wiring in between, or even the PCM.

Could also be a bad ASD relay, have you checked that out yet?

2005JGC 06-21-2012 03:02 PM

Re: PCM problem
 
I have seen this more than once, especially earlier wjs with 4.7's... I just replaced one last week for this concern, and replaced at least 2 last summer for this concern. Part of your problem to consider is that they dont make new pcm's for your 99 they are all going to be remanufactured and Im not going to speak on the reman process as I have no idea but I have seen reman parts out of the box have failures. I would talk with the service manager and see if he will work with you on the price considering your just out of the 12-12 warranty period (at least by time). Dont go especting a free one but you may get lucky and get some help on the price.

JeepFreak12 06-21-2012 04:32 PM

Re: PCM problem
 
I thought it was the skim module also. That's why I was going to the dealer to see if they could test it, that's when they told me the PCM was losing connection. I just put in a new asd relay to see if that helps. Fingers crossed

2005JGC 06-21-2012 07:44 PM

Re: PCM problem
 
When it dies will the vehicle crank but not start? if so your skim is working as designed. if your skim is fubar then it wont allow the vehicle to crank, if your pcm looses its power then the vehicle will crank but not start... also noted by the resetting of any dtc's that may or may not have been in the pcm.

Frango100 06-21-2012 09:37 PM

Re: PCM problem
 
Quote:

Originally Posted by 2005JGC (Post 646373)
When it dies will the vehicle crank but not start? if so your skim is working as designed. if your skim is fubar then it wont allow the vehicle to crank, if your pcm looses its power then the vehicle will crank but not start... also noted by the resetting of any dtc's that may or may not have been in the pcm.

Are you sure about the statement that the engine won´t crank when the SKIM is inoperative? As far as i can find the SKIS can shutdown the engine after 2 seconds when an invalid key is used, but it should crank normally.

And 4.7beast, what was the reason of the first PCM change?

2005JGC 06-21-2012 10:50 PM

Re: PCM problem
 
No you are right frank, I am not quite sure what I was thinking.

*edit* fwiw when the wcm fails in the WK grand cherokee which serves similar purpose as the skim module it typically wont turn over.

JeepFreak12 06-22-2012 05:04 AM

Re: PCM problem
 
When I bought my jeep it had PCM issues. And yes it cranks, and yes it clears all the codes.

Raptor 06-24-2012 06:29 PM

Re: PCM problem
 
Quote:

Originally Posted by 4.7beast (Post 646211)
My 99 4.7 randomly shuts off on warm days. I took it to the dealership and they said the pcm is getting hot and loosing connection. I just replaced the pcm a little over a year ago. Any one else have this problem? And when it shuts off i get the light on the dash of the key with a line thru it. Any help is much appreciated.

Do you have a 4.7 w/545RFE tranny? 1999 WJ V8 Limited w/quadradrive?
If thats your exact Jeep I may be able to help.

I have an OEM Mopar ECM for a '99 JCG Limited w/V8 & quadradrive sitting on a self in my gararge. The Mopar part # is 56041428AF. It was to be installed in my '99 before it was totaled years ago, it listed for $520.00, I'll let it go for ~ $300.00.....It's a brand new genuine OEM Mopar part, not rebuilt and might be exactly what you need. PM me

JeepFreak12 06-25-2012 04:07 AM

Re: PCM problem
 
Thanks but i have a spare that i pulled of my parts 99 grand cherokee with the same drive train.


All times are GMT -5. The time now is 12:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community