Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior/Visual (http://www.jeepgarage.org/f176/)
-   -   installed mygig 430N Nav (http://www.jeepgarage.org/f176/installed-mygig-430n-nav-43878.html)

gc4x4 06-26-2012 01:57 PM

installed mygig 430N Nav
 
2 Attachment(s)
I just installed the mygig 430N RHB nav radio in my new jeep and it works great right off the bat, i already have the microphone setup in the mirror and everything works perfectly including the Nav, which i was surprised because it seems to work fine without an external antenna.:D Best thing is it looks stock..

eibyer 06-26-2012 02:43 PM

Looks great and it does look stock. Is it a new unit or a pull?

armoredsaint 06-26-2012 02:49 PM

Re: installed mygig 430N Nav
 
no pics of the installation process? :nutkick:

gc4x4 06-26-2012 03:17 PM

Re: installed mygig 430N Nav
 
Quote:

Originally Posted by armoredsaint (Post 648358)
no pics of the installation process? :nutkick:

due to eagerness to install i completly forgot lol, but you just pop the hvac trim off take out the 4 bolts on the old radio,pull out old radio, unplug wires, then plug everything into new radio install bolts and trim and voila your done...:thumbsup:

gc4x4 06-26-2012 03:19 PM

Re: installed mygig 430N Nav
 
Quote:

Originally Posted by eibyer (Post 648355)
Looks great and it does look stock. Is it a new unit or a pull?

It was a new pull from a 2011 limited with 200 miles..

Schweibs 06-27-2012 09:46 AM

How much did it cost?

gc4x4 06-27-2012 12:00 PM

Re: installed mygig 430N Nav
 
Quote:

Originally Posted by Schweibs (Post 648753)
How much did it cost?

I paid $735 with free shipping, the dealer wanted almost $1500 for the same radio, thats crazy...:eek:

JEEP SMC 06-27-2012 12:57 PM

Re: installed mygig 430N Nav
 
did the dealer have to flash it or anything? and does it also work with your EVIC as to show the turn by turn?

AAAA 06-27-2012 04:34 PM

Re: installed mygig 430N Nav
 
Did you need a code to unlock the anti-theft feature?

JEEP SMC 06-28-2012 07:49 AM

Re: installed mygig 430N Nav
 
Y u no respond!

gc4x4 06-28-2012 01:22 PM

Re: installed mygig 430N Nav
 
it was plug n play with no dealer trip. No this radio doesn't have anti theft feature i believe.. plugged it in and it worked right away.

Justal13 06-28-2012 04:01 PM

Re: installed mygig 430N Nav
 
If you get a 2011 430N (high speed bus), you do not need the security code. The security code was added for the 2012 media centers across the line (130, 430, 730 series) as a theft-prevention measure. So if you get a 2012 unit, make sure you get the code from the seller (usually the last 4 digits of the serial number of the vehicle it came out of). Otherwise, it will be a trip to the dealer and hope they will look it up for you on their scan tool. Many dealers are reluctant to do this, as not having the security code is the 1st indication the unit may be stolen. I had to do this on my son's GM a few years ago, and even with all the proper paperwork I had to go to the dealer's manager and a few phone calls to GM to get the permission to change the code in their scan tool.

This link gives you all the information on the 2011 - 12 GC radios, including installation - swap/upgrade guides.

http://wk2jeeps.com/wk2_navigation.htm

By the way, a few weeks ago on the forums somebody was trying to sell a GC media center that they bought off eBay and the code that was provided from the seller did not work. Buyer beware.


All times are GMT -5. The time now is 12:15 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community