Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Electric fan not running (http://www.jeepgarage.org/f203/electric-fan-not-running-43947.html)

linenfelserrogdr 06-27-2012 11:06 AM

Electric fan not running
 
I have a 2002 WJ with the 4.0. The other day it began to overheat when sitting still. Come to find out the electric fan doesn't kick on. I replaced the coolant temp sensor yesterday. Still nothing I was wondering what you guys think, and possibly suggest a course of action. Thank you.

bumnt 06-27-2012 01:30 PM

Re: Electric fan not running
 
Another victim of the electric fan relay failure.

You can replace it (go OEM!) and it'll ultimately fail again, or you can add a mechanical clutch fan and forget about the electric.

I'm sure there are threads here that detail how to replace it, but essentially you pull the passenger side headlight and cut out a piece of plastic to reveal the relay.

-Kyle

hoffmanestates 06-27-2012 07:52 PM

yup try relay or check connection and wires

Turbo charged G2X using tapatalk 2

Frango100 06-27-2012 07:56 PM

Re: Electric fan not running
 
Also many times the relay fries because of the fan which is drawing too much current. Don't know the max acceptable current though.
Also check fuse first before ripping it apart.

linenfelserrogdr 06-27-2012 10:36 PM

Re: Electric fan not running
 
Thanks guys. Relay below passenger side headlight. Literally.


All times are GMT -5. The time now is 11:04 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community