Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   06 3.7 sputtering & jerking (http://www.jeepgarage.org/f181/06-3-7-sputtering-and-jerking-44081.html)

Loyd 06-30-2012 12:17 PM

06 3.7 sputtering & jerking
 
On a trip this week it started jerking and sputtering. Stopped off at a small shop who read codes that indicated poor fuel economy. They interpreted to be missing, but could not get a code that identified which cylinder. Pulled the #1 plug and found it was well overdue for replacement. Replaced all six, and it cleared all codes and ran great for about 200 miles... Then started all over again! What now?

05wkguy 06-30-2012 12:46 PM

Re: 06 3.7 sputtering & jerking
 
Oxygen sensor is my next suggestion. How many miles on the truck?

Loyd 06-30-2012 12:56 PM

Re: 06 3.7 sputtering & jerking
 
Just topped 83k while on the trip. Ran fine previously.

05wkguy 06-30-2012 02:21 PM

Re: 06 3.7 sputtering & jerking
 
Since it ran fine before I would now guess it's not the O2 sensors. Think you'll have to break down and get the dealership to scan it a little more in depth.

Duff Daddy 07-01-2012 03:20 PM

Re: 06 3.7 sputtering & jerking
 
I would look to possible carbon on the back of the intake/exhaust valves causing it not to seat properly and causing an intermittant miss. This is something you will see on a 3.7....


All times are GMT -5. The time now is 03:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community