Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   5.8~6 MPG in city... (http://www.jeepgarage.org/f181/5-8-6-mpg-in-city-44328.html)

Jarek5_7 07-06-2012 06:22 AM

5.8~6 MPG in city...
 
5.8~6 MPG in city, below ~40mph. I checked o2 sensors, one was bad, voltage was steady, but after clearing connector it showed good results (scanned on computer by a mechanic). before it consumption was around 40l/100km so about 6mpg !!! after that I reset the pcm and mpg on computer and it states the same or little more??.

I have only 0499 fault which is nvld fault. can it be a problem?
car has power, and runs smooth.

where to look, any ideas?

dr.lee.baugh 07-06-2012 08:52 AM

Re: 5.8~6 MPG in city...
 
Have you calculated your MPG manually to make sure the trip computer is correct?

How long did you drive it after the reset? It takes a while for the computer to re-calculate a stable average (something like 30 miles of driving).

I have a hard time believing you could be getting 6 MPG without any driveability issues or DTCs being set, unless you are forgetting to shut the engine off over night...

Scottina06 07-06-2012 08:53 AM

Re: 5.8~6 MPG in city...
 
more details please...engine? 4x4 or 4x2? miles? year?

Jarek5_7 07-06-2012 04:04 PM

Re: 5.8~6 MPG in city...
 
4x4, 2005, 42k km.

I fill up the tank to full, drove 50km in the city by next two days and then a little over 20 litres went into tank.

Its wierd for me too, its two times more than it should be I think and there are no driveability issues. engine isnt stalling, it has power, doesnt make black smoke...

CPT2010 07-06-2012 04:55 PM

Re: 5.8~6 MPG in city...
 
gas leak somewhere? lol

Verminator 07-06-2012 05:11 PM

Re: 5.8~6 MPG in city...
 
is it stock or do you have any mods done? Is maintenance all up to date?

Jarek5_7 07-07-2012 05:35 PM

Re: 5.8~6 MPG in city...
 
I bought it some time ago, fixed tranny, changed trans fluid, I`ll change engine oil next week. no mods, mds works, I can feel it operate.

Jarek5_7 07-08-2012 02:11 AM

Re: 5.8~6 MPG in city...
 
As I wonder now, I dont think the car starts normally.

As I start it it cranks and sudenly start and very fast rpm goes to 2k, and then drops to idle, but its like vroom and fast rising to 2k. Like I would hold accelerator pedal for ahalf of second while starting.

I dont think it revs should go that high on start up.

leaky injector?

Verminator 07-09-2012 03:17 PM

Re: 5.8~6 MPG in city...
 
Possible. Any erratic idling or random stalling?

Walt 07-09-2012 05:25 PM

Re: 5.8~6 MPG in city...
 
Quote:

Originally Posted by Jarek5_7 (Post 652578)
5.8~6 MPG in city, below ~40mph. I checked o2 sensors, one was bad, voltage was steady, but after clearing connector it showed good results (scanned on computer by a mechanic). before it consumption was around 40l/100km so about 6mpg !!! after that I reset the pcm and mpg on computer and it states the same or little more??.

I have only 0499 fault which is nvld fault. can it be a problem?
car has power, and runs smooth.

where to look, any ideas?

NVLD is the gas tank emissions system. Do not "overfill" your gas tank because there is a check valve for vapors to flow into the system, etc, etc, and will throw these codes if liquid goes through. I had a valve in the system go bad (under warranty) and mileage was definitely down at the time.

Not sure if the DTC can directly affect mileage, but disconnect negative battery cable push brake pedal to discharge voltage. It will reset adaptives and any codes.

Check 1 thing also: On the driver's side, near the power distrib. centers, there is a solenoid that sticks up. It vents gas tank vapors into the intake manifold. Make sure the discharge side is actually connected to your manifold. They sometimes get knocked off. That might also cause a DTC, not to mention a free passage of air directly into your intake manifold, bypassing the throttle body butterfly valve.

Jarek5_7 07-10-2012 02:49 AM

Re: 5.8~6 MPG in city...
 
solenoid under the hood is connected and intake doesnt draw air from loose hoose etc.

I followed instructions from service manual regarding code 499 it turned out to "replace nvld assembly". when I bought the car it was very hard to fill tank with fuel, now its ok because I removed nvld pump and poured out some water. I presume someone overfilled it and some gas stayed in hoose but it evaporated and only yellowish odorless fluid left in that hoose.

nvld pump needs replacing, its rusted inside.

Jarek5_7 07-10-2012 10:09 AM

Re: 5.8~6 MPG in city...
 
I dont know if nvld pump can cause that poor milage...


also after fixing o2 sensor connection msd started to work and I dont like it :(

I think its msd, because at low rpm, for example 30mph 1500 rpm it kicks in rpm rises , after second or two msd turns off. sometimes when cruising in the city for exmaple 40mph and slitly pressing accelerator it hesitetes for a second and them accelerate rapidly, too rapidly for this slight pedal pressing.

no codes expet P0499..


All times are GMT -5. The time now is 12:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community