Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Immobiliser Problem? (http://www.jeepgarage.org/f203/immobiliser-problem-44417.html)

Father Tiresias 07-08-2012 05:38 AM

Immobiliser Problem?
 
Or not!!!

Went out in the car yesterday and did a sixty mile round trip with a couple of stops on the way with no problems. Later on in the evening I wanted to move the car but it refused to start. Tried again this morning and its the same. I initially suspected the immobiliser was at fault but now I'm not so sure.

When the ignition is turned on the radiator fan immediately starts working (even with a cold engine). The instruments do not behave in a normal way, none of the gauges are working - see the YouTube clip for what I mean.

http://www.youtube.com/watch?v=7yt7g...ature=youtu.be

All of the cars other electrics seem to be working fine. Any suggestions as to what could be causing this?

Father Tiresias 07-08-2012 05:52 AM

Re: Immobiliser Problem?
 
More info:

The battery was taken off last night and fully charged over night in the hope that something would re-set, but it didn't.

I have tried reading fault codes from the OBD socket and my (generic) scanner will not make connection (previously it worked fine). So I tried to display the fault codes using this procedure:

Turn the ignition key until the digital odometer displays, repeat three times in succession and then back to "On" (On/Off, On/Off, On/Off, On). At the fourth "On" the odometer will be replaced with codes. If no codes are present then "Done" will appear.

This doesn't work either (it previously did). I'm beginning to think that there is a comms issue here somewhere or its something to do with the instrument cluster.

Duff Daddy 07-08-2012 07:24 AM

Re: Immobiliser Problem?
 
Thats not a Skim issue. If it was and the "chip" or skim module issue. Normally when the skim module doesnt see the right code or is unplugged what will happen the car will start, run for 2-3 seconds, and shut off, if this is tried more then three times then the car wont start any more. Thats when it gets towed in to be "unlocked"

Frango100 07-08-2012 09:49 AM

Re: Immobiliser Problem?
 
There indeed seems to be a problem with the data bus. You could remove the respective components one by one from the data bus and see if it returns. There seems to be a data bus crosspoint somewhere below the steering wheel area, where you can disconnect each one.
I would start first checking all fuses in PDC under the hood and the junction block under the steering wheel, especially the PCM fuses. ( Fuse 12 on JB and fuses 6, 19 and 26 in PDC)

Father Tiresias 07-08-2012 01:57 PM

Re: Immobiliser Problem?
 
Done a bit more checking today. All fuses in both the PDC and PCM check out as fine with a DMM. I dismantled the dash to get the BCM out to check the condition of the various connectors and wiring. Removed them all and all looks OK. All put back together again and still the problem is there. I also carried out the diagnostic on the instrument cluster (ignition on whilst holding down the trip reset) and that appears to be functioning fine.

I have read on another forum about someone with a similar problem and it turned out to be either the cam or crank sensor (he replaced both). I kind of find it hard to believe that either would create this fault - I would think that they would turn on the MIL light and generate a code.

Tomorrow if I get a chance I will take a look at the engine and see if its getting a spark and/or fuel pressure. I'll also see if it is possible to 'scope the output of the sensors.

Presumably if its a coms fault it should shut the ECU down completely and prevent a spark or any fuel pressure?

Duff Daddy 07-08-2012 03:26 PM

Re: Immobiliser Problem?
 
It doesnt have to be an open in a crank or cam to make the car not start, it can be an issue of it not seeing the reluctor wheel thus giving a faulty reading. It does happen, worst case we once thought it was a crank sensor to find out the flex plate had few small cracks and was causing an intermittent miss/stalling condition...

Father Tiresias 07-08-2012 03:44 PM

Re: Immobiliser Problem?
 
Would that cause the lack of working instruments though? I can understand it causing a tacho fault if it can't read the engine speed, but what about battery voltage and fuel tank?

Duff Daddy 07-08-2012 07:03 PM

Re: Immobiliser Problem?
 
not necessarily, your right the tach would be inoperative but the others SHOULD work. Unelss this is a wiring issue as stated above. I would like to see if its getting ignition, if its not, and the pcm is seeing a cam and crank signal, it could be a pcm or wiring from the pcm out.

jlgo222 07-09-2012 07:23 AM

Re: Immobiliser Problem?
 
The first thing i would check and its super easy (helped diagnosis my problem) remove your pcm and check the outside housing for any rough damage, not liekly. But then open up the pcm likely ur warranty is already house so no problems there. then go thru and check for burnt/broken circuit traces. I found about a half of dozen inside mine. If needed i can up load pictures later this evening.

Frango100 07-09-2012 09:43 AM

Re: Immobiliser Problem?
 
Also would not expect cam or crank sensor in this case. If one is shorted, it can bring down the 5v supply, but it should not affect the data bus output.
What JLGO222 mentioned is a bigger possibility. What i understand is the PCM the center of the data bus system, so problems in there can bring the bus down.

Father Tiresias 07-10-2012 02:03 PM

Re: Immobiliser Problem?
 
Well, I removed the PCB tonight and just out of interest turned the ignition on to see what happens with the instruments - exactly the same as with the PCM connected (see previous YouTube clip). I assume the 5v reference supply is generated within the PCM so disconnecting the PCM should prevent the 5v from dragging anything else down.

I have removed the screws from the cover of the PCM but how does it come apart? The cover won't budge!!

If it is a data bus problem I'm wondering what else I can disconnect to isolate various parts of it. Presumably there are outstations in the doors so they could be disconnected. The BCM would be needed to try and start the car so is there anything else that I can disconnect?

Frango100 07-10-2012 03:10 PM

Re: Immobiliser Problem?
 
There is a central connection point where the data bus wire from all connected components join together, somewhere under the steering wheel area. From there you could disconnect one by one. So i can't tell you exactly where it is. Have a llok via the search option if you can find it, it was discussed before by an other member.
I think that the PCM is kind of the master in the data bus system, when you remove it, nothing else will function on the bus. So there is a good change that the PCM is the fault.


All times are GMT -5. The time now is 08:16 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community