Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   4.7 HO rebuilt, need ground locations (http://www.jeepgarage.org/f203/4-7-ho-rebuilt-need-ground-locations-44486.html)

Dawoodster 07-09-2012 06:25 PM

4.7 HO rebuilt, need ground locations
 
Hi Guys,

I blew my motor in my 04 GC Columbia last year and finally got around to rebuilding it and stabbed it last weekend. Got her all buttoned up, but didn't tag some ground wires and would like to get back to the factory locations.

Minor background: I basically broke a valve spring, which bent and sheered the valve stem and the sheered piece decided to do some touring through the top end where some carnage insued.

I decided on a "budget" rebuild; no machine work other than the victimized head, but new bearings, pistons, timing set, etc.

BTW, I've got it 98% and realized this morning I pulled a major boner and missed the knock sensors, so I'm removing most the above-ground components (again)... I'm just waiting for my face to stop hurting after slapping the crap out of myself. :slapfight:

Back to the grounds, here are some pics, any help will be much appreciated:


This is left front, (my battery box is removed); reaches a lot of areas, read elsewhere it went to body bolt but doesn't seem likely since I don't have any loose
http://i70.photobucket.com/albums/i9...7-09073504.jpg


Right front by motor mount; I have a bolt and clear point of attachement on block, just want to make sure
http://i70.photobucket.com/albums/i9...09073826-1.jpg

Left front: secured at block, but again, I just want to confirm
http://i70.photobucket.com/albums/i9...7-09073845.jpg

Houston... I found the problem :eek:
http://i70.photobucket.com/albums/i9...p/IMAG0473.jpg

01grand 07-10-2012 02:04 PM

Re: 4.7 HO rebuilt, need ground locations
 
Yikes, you certainly did bend that valve stem! I believe that ground attaches to the body, there should be a ground that attaches to the body by the battery. Let me see if I can go get a pic....

Here is a general view, there are 2 grounds it looks like between the body and PDC
http://i1087.photobucket.com/albums/...l1020614PM.jpg

And here is a closer up shot of the one it looks like, I have 2 wires there, one is for my HID kit
http://i1087.photobucket.com/albums/...l1020630PM.jpg

Dawoodster 07-10-2012 05:30 PM

Re: 4.7 HO rebuilt, need ground locations
 
Aaron, thanks for taking the time. The ground in your pic is still in tact on mine, I didn't have to remove it. It is the same gauge wire, though. I took a new pic of the one in question:

it comes off positive battery cable harness, lone heavy gauge wire about 18" or so, I put orange tape on it where it exits the harness. BTW, the # on the bar code label is P56050277AD. In my "before" pics, it looks like it might go down and back, but just can't quite tell.

http://i70.photobucket.com/albums/i9...7-10093507.jpg

And just to keep the fun going, I got everything off and back on today to install the knock sensors, but in the process the intake fell off a 2' high self, and landed perfectly to break the MAP sensor:mad: Anyone know how much beer and tylenol it'll take the make the pain stop...

Dawoodster 07-10-2012 10:49 PM

Re: 4.7 HO rebuilt, need ground locations
 
I'd still appreciate it if anyone can confirm the factory location for this. In the meantime, I went ahead and secured to the block with the other grounds. I did get it started today, fired on the first try :thumbsup:, seems to be fine, but I'm treading lightly.

cheapjeep 07-11-2012 03:56 AM

Re: 4.7 HO rebuilt, need ground locations
 
I think Aaron is right. There is more than 1 wire that goes to the body ground by the PDC. I'll double check this later.

Ben_02WJ 07-13-2012 08:24 AM

Re: 4.7 HO rebuilt, need ground locations
 
I went out and looked at my '02 and it looks like it goes down to the bottom of the block, but since I am at work right now I can't crawl under it to verify exactly where it goes. My guess is you have it in the right position with the rest of the grounds on the block.

Dawoodster 07-13-2012 12:33 PM

Re: 4.7 HO rebuilt, need ground locations
 
Ben... Thanks for checking.

In case anybody has their head under the hood and can check to put a definitive answer to this, here's one more pic showing the wire in question, still marked with orange tape coming of the battery harness and showing the two ground locations behind the PC, where I'm still sure this doesn't go.

Again, thanks to all for taking the time... keep it rubber down

http://i70.photobucket.com/albums/i9...7-12163744.jpg

Ben_02WJ 07-13-2012 02:16 PM

Re: 4.7 HO rebuilt, need ground locations
 
I crawled under my Jeep and took a picture of where it looks like that wire is going. I would need a second person to "jiggle" the wire or not be wearing my good cloths (a little muddy under there :D) to be 100% certain. It looks like it goes on the passenger side of the block with two other smaller grounds (each with 2 approximately 14 gauge wires attached).

Here is a picture of what I have:
https://lh5.googleusercontent.com/-E...8-k/12%2B-%2B1

Hope this helps!

Dawoodster 07-13-2012 10:38 PM

Re: 4.7 HO rebuilt, need ground locations
 
Thanks again, Ben.. If you're ever in SoCal, the first 3 rounds are on me :chug:

Ben_02WJ 07-13-2012 10:43 PM

Sounds like a plan :beer:


All times are GMT -5. The time now is 09:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community