Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Export Grand Cherokee 2011+ (http://www.jeepgarage.org/f190/)
-   -   Radio not working! (http://www.jeepgarage.org/f190/radio-not-working-44689.html)

JCMEVANS 07-14-2012 01:59 AM

Radio not working!
 
Hi everyone, today the radio stopped working on the Overland. I still can listen to the rear DVD and CD player and the phone still works through the speakers but both the usb connections and radio dont have any sound or volume control!!! Has anyone got any thoughts or had any problems with this?

scarps 07-14-2012 02:24 AM

If everything else is working ok, it could just be a little computer bug.
Not an expert in this area but sometimes find with things like this, they correct themselves a day or two later, or on the morning you've booked it into the dealer to fix:-)
Maybe reboot the computer.

allypally 07-14-2012 03:26 AM

Re: Radio not working!
 
Simplest solution is to disconnect battery

*sox* 07-14-2012 04:26 AM

Re: Radio not working!
 
Quote:

Originally Posted by allypally (Post 656336)
Simplest solution is to disconnect battery

rigth!:thumbsup:

JCMEVANS 07-16-2012 03:47 PM

Re: Radio not working!
 
Thanks guy's, it came good overnight so I will keep an eye on it and see what happens.

JonF 08-16-2012 09:19 PM

Re: Radio not working!
 
Mine did this toninght. 2012 Laredo. I shut the Jeep off and restarted and the same thing. No sound and no response from volume controls. No radio, no CD. I shut it off again for about 5 minutes then it started working normally when I restarted it.

I dont have the radio option code in front of me but it's AM/FM/Sirius with voice control and U-connect.

GMWK2 08-16-2012 09:36 PM

Re: Radio not working!
 
The bluetooth connection to my iphone stops working from time to time. When I try and play music, comes up with a message in the display "Initialising" then "This device no longer available" and wont play music. Phone still works via bluetooth so very odd.

I have a cable and just plug the iphone into the Aux jack as a work around.

It fixes itself in a few days for no apparent reason.

savvas 08-16-2012 11:51 PM

Re: Radio not working!
 
Quote:

Originally Posted by GMWK2 (Post 671559)
The bluetooth connection to my iphone stops working from time to time. When I try and play music, comes up with a message in the display "Initialising" then "This device no longer available" and wont play music. Phone still works via bluetooth so very odd.

I have a cable and just plug the iphone into the Aux jack as a work around.

It fixes itself in a few days for no apparent reason.

That might be an iphone thing.

My Blackberry, my wife's Sony android phone and my son's nokia all stream fine all the time. My daughters iphone 4 is often a problem though.

GMWK2 08-17-2012 12:19 AM

Re: Radio not working!
 
Quote:

That might be an iphone thing
I suspect you are right.

AussieWK2 08-17-2012 07:51 PM

Re: Radio not working!
 
Quote:

Originally Posted by savvas (Post 671601)
That might be an iphone thing.

My Blackberry, my wife's Sony android phone and my son's nokia all stream fine all the time. My daughters iphone 4 is often a problem though.

ok.....just gotta ask...

When you're all in the car at the same time who gets to choose the device? :lol:

Tinkan 01-25-2014 12:52 PM

Re: Radio not working!
 
Quote:

Originally Posted by AussieWK2 (Post 671906)
ok.....just gotta ask...

When you're all in the car at the same time who gets to choose the device? :lol:

When you set the device to pair you had also set a priority to each device. The highest priority is the one connected. The girl friend made hers the highest priority. I will not argue with her.

SNUKE 01-25-2014 05:58 PM

Re: Radio not working!
 
Quote:

Originally Posted by Tinkan (Post 965338)
When you set the device to pair you had also set a priority to each device. The highest priority is the one connected. The girl friend made hers the highest priority. I will not argue with her.

I had an interesting result with this yesterday.
The system was streaming music from my phone via bluetooth, it did so automatically when I switched to BT option (I was driving, car set to my preferences).
The phone rang and was shown on the Uconnect screen, it was coming through from the other phone, which was set to have priority.

So there must be at least two BT radios in the car for both to be paired at once and working. I simply thought that like most cars and BT devices there would only be one, and when scanning it paired the prioritised one in the list.


All times are GMT -5. The time now is 09:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community