Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   o2 crapped after motor rebuild.. (http://www.jeepgarage.org/f203/o2-crapped-after-motor-rebuild-44901.html)

hoffmanestates 07-18-2012 09:05 PM

o2 crapped after motor rebuild..
 
so i am getting o2 codes for either efficency or something:( ill post tommorrow morning when i scan with scan gauge.. i have emissions testing due in end of august..... i know everyone says oem but are these 4.7 that finicky on o2.? i called dealer they quoted me almost 200 each. i went to mopar website and they say 80....do i chance it or have to bite bullet. and go dealer,:mad:, or did a fuse pop?:confused: i remember some cars have fuses for o2 but idk if jeep does...

Frango100 07-18-2012 09:55 PM

Re: o2 crapped after motor rebuild..
 
The O2 sensors on the Jeeps are from Denso, so you could look for those. The Bosch ones give problems due to the longer heatup time.
Depending on which emission system your Jeep has, there is (are) one or 2 fuse(s) in the PDC for the O2 heaters.

hoffmanestates 07-19-2012 05:29 AM

OK ill look

Turbo charged G2X using tapatalk 2

hoffmanestates 07-19-2012 06:03 AM

0159 0141 0161. my codes

Turbo charged G2X using tapatalk 2

Frango100 07-19-2012 06:41 AM

Re: o2 crapped after motor rebuild..
 
Indeed all O2 sensor related.
P0141 = Heater performance bank1
P0159 = Slow response bank 2
P0161 = Heater performance bank 2

There is a common fuse in the PDC, fuse 16, for the O2 heaters. For the downstream sensors there is also a relay in the PDC and seems that for some models that there is even a relay for the upstream sensors.
Would not expect both sensors to be bad at the same time, maybe a wire damaged or just the fuse blown?

hoffmanestates 07-19-2012 09:06 AM

well coolant was leaking.into #8 and burning it so its either that or.any wires that run along passenger head area

Turbo charged G2X using tapatalk 2

hoffmanestates 07-21-2012 09:19 AM

fuse and relay are OK.

Turbo charged G2X using tapatalk 2

hoffmanestates 08-02-2012 09:36 PM

so I'm doing this fix this weekend . I know its gonna be.a 50/50 if its a cat issue.or o2 issues. now that I posted my codes how many o2 sensors do I have? I found carquest sells denso.60-70 each. for upstream and 90 each downstream ... looking at my codes which ones would I need? both on right side or all 4? if there are four ....

G2X tapaTalk

cheapjeep 08-02-2012 10:15 PM

Re: o2 crapped after motor rebuild..
 
I'd at least change both front and rear on the #8 side. Antifreeze seems to take them out every time.

hoffmanestates 08-03-2012 12:44 PM

both front? there are two on the.pre cat and.one after cat? if so holy crap. ill do all "4" if they exist per carquest

G2X tapaTalk

Frango100 08-04-2012 12:40 PM

Re: o2 crapped after motor rebuild..
 
Depending on the emission package your jeep has, there are some options. But as Dave says, start changing the bank 2 upstream and downstream sensors and see what it does.

hoffmanestates 08-04-2012 12:47 PM

OK will do

G2X tapaTalk


All times are GMT -5. The time now is 06:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community