Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2006 Grand Cherokee Laredo lost communication with the TCM again! (http://www.jeepgarage.org/f181/2006-grand-cherokee-laredo-lost-communication-with-the-tcm-again-45025.html)

Oscarq 07-22-2012 06:42 PM

2006 Grand Cherokee Laredo lost communication with the TCM again!
 
Ok, I'm frustrated and stressed out! My jeep started having issues a couple months back. Esp and bas lights would come on, as well as the skidding (traction?) light as well. Would continue to run fine. Then, the trans over temp light started coming on at random and the check engine light came on. Started downshifting every now and then. I would have to pull over and restart it . Sometimes would seem to lose power.The trans over temp would sometimes even come on at start up, first thing in the morning. Brought it to a well known transmission repair shop. They checked it out and replaced the Front controller module and transmission control module. Apparently, it lost communication with the TCM. Two weeks and $1800.00 later, I get it back, drive 15 miles, shut it off, turn it back on, 10 minutes later the esp, bas, and trans over temp comes back on. Only downshifted on me once so far. Got it home, went back out, no lights, no problems. Today, ALL the lights are back on including the check engine light. Brought it to Autozone, they checked it and it threw the same code, Lost communication with the TCM. Supposed to bring it back to the shop tomorrow, not sure what's going on here. I have read alot of negative feedback about this particular jeep with the SAME problem. It's not wheel sensors, no alignment issues, fluid is fine, no leaks. Does anyone know what the hell to do with this jeep? It has 68,000 miles on it

2005JGC 07-23-2012 02:00 AM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
I have never diagnosed two controllers for the same problem before... EVER! That is some amazing diagnostician they have working on your rig. Oh wait, guess neither of those dice fixed the problem.

What exactly are the dtc's your getting?

Oscarq 07-23-2012 07:57 AM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
Lost communication with TCM

2005JGC 07-23-2012 12:47 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
no the P-U-C codes ex. PXXXX any and all of them that were pulled.

Oscarq 07-23-2012 01:55 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
UO1O1
Just left it at Aamco. Waiting for a call. Autozone put it on their mini computer yesterday, same code as before the work was done. Lost communication with TCM...When we brought it to Aamco they ran a full computer diagnostic, said it threw 8 codes, Changed the front controller module. They said that cleared 7 of the 8 codes. Replaced the TCM with a reconditioned one and supposedly that cleared the last code. They said they drove it and no problems, all the codes cleared. I did note the milage when I dropped it off, there was a 27 mile difference. They didn't tell all what the 8 codes were. I picked it up Friday, drove about 20 minutes with no problems, shut it off for a few minutes, 5 minutes down the road all lights are back on, except the check engine. They go off when I restart it for a few minutes. Saturday the check engine light came on and hasn't gone back off. Occasionally it downshifts on me.

2005JGC 07-23-2012 04:19 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
From chrysler... you may need to get it to the dealer, Aamco wont be able to do this!

Quote:

Case NumberK68152119 Vehicle IssueU0101, Loss of communication with TCM.;The symptoms are as follows: DTC U0101 - Lost communication with TCM. Multiple dash lights on SES, ESP, BAS, etc... Can't communicate with TCM. Harsh or no shifting. Vehicles Build Date between 11/13/05 and 12/25/05System or ComponentInoperative,No Shift / Will not Shift Up or Down;DTC / Error Message;TCMRecommendationThe root cause is that the Trans Relay is missing from the junction box. The tech's will need to install a relay. Available documentation does not provide the location of the Junction Box. It's located under the dash on the driver's side to the right of the steering column. The trans relay is not visible from the front of the Junction Box. Once the relay is installed, you will get the following code, P1644 (Incorrect Variant Configuration) for which you need to initialize EGS52. The initialize function can be found under ECU View, TCM, More Options; Followed by a P0602 (Control Module Programming Error/Not Programmed) which requires a reflash sometimes multiple times. Once the trans relay has been installed and the error codes cleared, the vehicle needs to be checked for a harsh 1-2 upshift. Under medium throttle allow the vehicle to upshift to second. If a harsh 1-2 upshift is noted, it is likely that the F1 ORC in the transmission has failed and the following components will need to be replaced: 3.7L Engine - K1 Retainer 52108510AB, F1 Over-running Clutch 52108342AB, and B1 Retainer 05138365AA. As of 3/20/06 Star Parts specifies the K1 Retainer as 52108510AA. This is incorrect and the AB level part should be ordered

croth 07-23-2012 05:30 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
Quote:

Originally Posted by 2005JGC (Post 660377)
From chrysler... you may need to get it to the dealer, Aamco wont be able to do this!


Holy crap Batman! Nothing is simple anymore is it?

stashgto 07-23-2012 05:30 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
What has AAmco had to say about the $1800.00 you paid with no results?

Oscarq 07-24-2012 11:36 AM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
"bring it in so we can check it out" brought it in yesterday, haven't heard anything yet.

Oscarq 07-24-2012 11:41 AM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
Quote:

Originally Posted by 2005JGC (Post 660377)
From chrysler... you may need to get it to the dealer, Aamco wont be able to do this!

Sounds expensive : ( waiting for Aamco to call

Antonio186 07-24-2012 12:07 PM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
thats some excellent info.

Quote:

Originally Posted by 2005JGC (Post 660377)
From chrysler... you may need to get it to the dealer, Aamco wont be able to do this!

Quote:

Case NumberK68152119 Vehicle IssueU0101, Loss of communication with TCM.;The symptoms are as follows: DTC U0101 - Lost communication with TCM. Multiple dash lights on SES, ESP, BAS, etc... Can't communicate with TCM. Harsh or no shifting. Vehicles Build Date between 11/13/05 and 12/25/05System or ComponentInoperative,No Shift / Will not Shift Up or Down;DTC / Error Message;TCMRecommendationThe root cause is that the Trans Relay is missing from the junction box. The tech's will need to install a relay. Available documentation does not provide the location of the Junction Box. It's located under the dash on the driver's side to the right of the steering column. The trans relay is not visible from the front of the Junction Box. Once the relay is installed, you will get the following code, P1644 (Incorrect Variant Configuration) for which you need to initialize EGS52. The initialize function can be found under ECU View, TCM, More Options; Followed by a P0602 (Control Module Programming Error/Not Programmed) which requires a reflash sometimes multiple times. Once the trans relay has been installed and the error codes cleared, the vehicle needs to be checked for a harsh 1-2 upshift. Under medium throttle allow the vehicle to upshift to second. If a harsh 1-2 upshift is noted, it is likely that the F1 ORC in the transmission has failed and the following components will need to be replaced: 3.7L Engine - K1 Retainer 52108510AB, F1 Over-running Clutch 52108342AB, and B1 Retainer 05138365AA. As of 3/20/06 Star Parts specifies the K1 Retainer as 52108510AA. This is incorrect and the AB level part should be ordered

Oscarq 08-19-2012 10:49 AM

Re: 2006 Grand Cherokee Laredo lost communication with the TCM again!
 
Good news! The jeep is fixed, $2000.00 and two modulars later... and a relay switch that kept shorting out. Thank God the jeep was equipped with a spare. So far no problems, has been running great for 2 weeks now. The modulars by themselves did not fix the problem. When we brought it back they found the relay switch shorting out. That was probably the problem all along. Thank you all for your input. This has been quite frustrating. In the three years I've owned this jeep, this has been the only problem, it has always been a very dependable vehicle. I appreciate all the comments and feedback. :)


All times are GMT -5. The time now is 10:42 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community