Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   OME Lift - Binding/Rubbing??? (http://www.jeepgarage.org/f181/ome-lift-binding-rubbing-45154.html)

HiddenTalent 07-25-2012 06:48 PM

OME Lift - Binding/Rubbing???
 
I've had my OME lift for over a year now, love it to death.

I've got Spidertrax spacers and wheels with plenty of backspacing. I did mod the pinch weld. No visible rubbing anywhere, even at full lock.

I seem to be binding somewhere rotational when turning the wheel even 1/4 turn. I'm thinking CV's? Not sure, but I've noticed it getting worse.

It doesn't happen at higher speeds, but happens at low speeds and 1/4 turns.

Any ideas?

Suggestions?

Thanks in advance.

2005JGC 07-25-2012 10:36 PM

Re: OME Lift - Binding/Rubbing???
 
check and make sure your speed sensor harness and brake lines are clear of your tires.

HiddenTalent 07-26-2012 10:32 AM

Re: OME Lift - Binding/Rubbing???
 
Will do. I looked to make sure brake lines were clear. I'll check again for wheel speed sensor.

My CV's wouldn't be binding would they? They aren't on an extreme angle or anything...

dsjr2006 07-30-2012 01:43 PM

Re: OME Lift - Binding/Rubbing???
 
It could easily be CVs, but if you have QDII it could be that it's time for a fluid change since its a Limited Slip Type diff that can cause binding from my experience.


All times are GMT -5. The time now is 05:00 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community