Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Wiper Speeds (http://www.jeepgarage.org/f181/wiper-speeds-45223.html)

tfranzone 07-27-2012 12:23 PM

Wiper Speeds
 
So the wiper speeds on my 08 WK are all not working right... they only work on the lowest speed and the last two settings work, but they both only go at the fastest speed.. nothing else is working in between.. its quite infuriating when its lightly raining out.

My guess is the fuse is blown? I'm assuming a new fuse will fix it? any ideas how to fix? and if its the fuse.. what specific fuse name or number do i need? and can I pick it up at a store or better to just order from say, justforjeeps?

dr.lee.baugh 07-27-2012 12:31 PM

Re: Wiper Speeds
 
There is a wiper high/low relay in the Integrated Power Module - I would start there, swapping it with a known good one. It takes the same relay as all the others in there, so you can try swapping with one from the fog lamps or something to test. The part number will be written on the relay itself, and they are only a few bucks from the dealership.

If that doesn't work, I would look into the actual wiper stalk to make sure that is functioning properly.

The wipers can also throw DTCs, but I think you need a StarScan to read those specific codes (I don't think the key dance or generic scanners will pull them). If swapping the relay doesn't solve it, this may be a quick way to find out what the cause is.

Good luck.

tfranzone 07-27-2012 12:44 PM

Re: Wiper Speeds
 
Quote:

Originally Posted by dr.lee.baugh (Post 662143)
There is a wiper high/low relay in the Integrated Power Module - I would start there, swapping it with a known good one. It takes the same relay as all the others in there, so you can try swapping with one from the fog lamps or something to test. The part number will be written on the relay itself, and they are only a few bucks from the dealership.

If that doesn't work, I would look into the actual wiper stalk to make sure that is functioning properly.

The wipers can also throw DTCs, but I think you need a StarScan to read those specific codes (I don't think the key dance or generic scanners will pull them). If swapping the relay doesn't solve it, this may be a quick way to find out what the cause is.

Good luck.

thanks. I'm actually installing fogs this weekend.. i was gonna see if i can get the starscan recognition from a dealer on the cheap since it takes 1 minute... so perhaps i'll mention the wipers and see if I can kill 2 birds with one dealer without them killing my wallet...

2005JGC 07-28-2012 06:46 PM

Re: Wiper Speeds
 
the turn signal stalk is going to be a mux circuit, variable resistance, so if some of the functions work but not all that tells you the body harness is functional, the message is getting where it needs to get, its just the switch failing. Replace the switch with your fog lamp install and that will probably get it.

tfranzone 07-30-2012 10:20 AM

Re: Wiper Speeds
 
Quote:

Originally Posted by 2005JGC (Post 662579)
the turn signal stalk is going to be a mux circuit, variable resistance, so if some of the functions work but not all that tells you the body harness is functional, the message is getting where it needs to get, its just the switch failing. Replace the switch with your fog lamp install and that will probably get it.


So by replacing the fog lamp/turn signal switch? on the LEFT of my steering wheel?... that can have an effect on my wiper switch on the RIGHT side of my steering wheel?

if thats the case then, cool..since I will be replacing the lights/fogs/turn signal multifunction switch for my fog install soon.. when I went a decently knowledgeable parts store near me(a few of the employees have lifted jeeps, but none WKs)... they said for the switch to be functioning but not in all forms.. it may be the entire switch.. not a fuse or relay.. but funny you mention your answer(which I just would like clarified on the left switch affecting the right switch controls)..bc they looked up multifunction switches for the WKs and only the turn signal/lights/fogs switch (the one on the left) was showing up for parts to replace... looked like you couldnt replace a wiper switch...

so basically, replace the opposite switch that controls my lights and that will fix my wiper switch fucntions on the opposite side??

2005JGC 07-30-2012 06:43 PM

No sorry, I was spacing, have my mind on other things right, your right the khakis have no bearing on the operation of the wipers.

Sent from my SCH-I500 using Tapatalk 2

tfranzone 07-31-2012 11:03 AM

Re: Wiper Speeds
 
Quote:

Originally Posted by 2005JGC (Post 663413)
No sorry, I was spacing, have my mind on other things right, your right the khakis have no bearing on the operation of the wipers.

Sent from my SCH-I500 using Tapatalk 2

gotcha. well thanks anyways... anyone else know what could be causing this/have a solution??

Am i gonna need a completely new wiper motor?! that would suck.

bmwfanatic 07-31-2012 11:19 AM

Re: Wiper Speeds
 
my wipers would only go to the high setting when they wanted to. Sometimes they wouldn't turn on for the first 2-3 clicks of the switch detents. I tried replacing the relays to no avail. Replacing the wiper stalk switch cured the problem. Super easy to do while you're replacing your headlight switch, just on the other side of the steering column. 10 min max job.

tfranzone 07-31-2012 11:33 AM

Re: Wiper Speeds
 
Quote:

Originally Posted by bmwfanatic (Post 663807)
my wipers would only go to the high setting when they wanted to. Sometimes they wouldn't turn on for the first 2-3 clicks of the switch detents. I tried replacing the relays to no avail. Replacing the wiper stalk switch cured the problem. Super easy to do while you're replacing your headlight switch, just on the other side of the steering column. 10 min max job.

Thanks Felix! I will see if I can order a wiper stalk.. apparently they are harder to get than the lights MFS.. hopefully that will fix me up.. it would be a real beeyotch if I buy a new stalk and then still not working... I'm holding you 100% accountable for this if it doesnt work!




JK. lol thanks again!:thumbsup:


All times are GMT -5. The time now is 10:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community