Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Simple Engine ground (http://www.jeepgarage.org/f203/simple-engine-ground-45638.html)

IndianaJeep4 08-04-2012 10:39 PM

Simple Engine ground
 
I just rebuilt my 4.7 but cant figure out where the engine ground goes( the ground coming off the upper body on the passenger side, has two ground loops one for each side of the enigine i presume) Does anyone know where these gorunds go? I tried a few places on top of the enigne at the plug sensor bolts but the wire just gets hot and smokes up. Its not the same for 6 cylinder WJ, i looked on my sisters. Appreciate any help. thanks.

JeepNut 08-05-2012 06:46 AM

Re: Simple Engine ground
 
Hot and smokes up..... bad earth! or is it the power wire your accidentally grounding?

FYI
Although mine is import version (right hand drive) I will imagine the grounds are the same just under the engine mount on the block. Just make sure the area is clean of paint, rust and smear a small amount of grease on the surfaces will keep them rust free.

cheapjeep 08-05-2012 07:35 AM

Re: Simple Engine ground
 
The grounds (braided flat wire)mount to the 2 rear ignition coil mounting studs.#8 passenger side.#7 drivers side but they shouldn't be getting hot. I think these 2 are mostly to cut down on radio noise and such.You might have missed another major engine ground somewhere causing those to be overloaded when starting or under a large electrical load.

IndianaJeep4 08-06-2012 05:33 PM

Re: Simple Engine ground
 
thanks guys. that ground works alot better. Now the engine codes are saying 6 coils are malfunctioning, which i find hard to believe. About to use the ohmnmeter to test them.

Frango100 08-07-2012 12:22 PM

Re: Simple Engine ground
 
Be sure that all ground connections are properly connected (on clean corrosion free area and fastened well). Do the 2 ground wires you have connected now still get warm/hot? If so, then there is a problem with a larger grounding wire.
Which codes do you get? Is the engine running normally?

IndianaJeep4 08-07-2012 06:13 PM

Re: Simple Engine ground
 
Those two ground wires are fine now. The codes are all ignition coil codes such as P0353. Its strange because everytime I start it up it says a different ignition coil is malfunctioning. I put dielectric grease on all eight ignition coil plugs but nothing changed. It will start normal(the very first try of the day) and idle fine then it starts misfiring(I'm thinking), the engine light comes on, and it cuts itself off. Restarting it, it misfires right away and i need to give it gas to even run.


All times are GMT -5. The time now is 08:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community