Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Weird A/C problem? (http://www.jeepgarage.org/f181/weird-a-c-problem-45783.html)

remmy 08-08-2012 07:12 AM

Weird A/C problem?
 
Is there any particular reason why one side of my WK blows ice cold and the passenger side not so much? The Jeep has 95k on it and probably needs a refill(never done it, don't know how to). Anybody have this problem?

dr.lee.baugh 08-08-2012 08:21 AM

Re: Weird A/C problem?
 
I doubt it has to do with the charge in the system.

If you have the dual-zone climate, the passenger side blend-door is a likely culprit.

remmy 08-08-2012 06:56 PM

Ok, so it's the blend door actuator has takers a dump I presume? I looked it up in my car manual and looks pretty simple and straight forward to fix.

What are your thoughts?

remmy 08-08-2012 07:30 PM

I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.

Galaxie500 08-08-2012 07:49 PM

Re: Weird A/C problem?
 
Quote:

Originally Posted by remmy (Post 667656)
I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.

Not sure where you got that info but it's a real problem in our Jeeps. I do not have the Auto Climate System, just manual, and I had to have the fix done. Fortunately my Jeep was still under warranty. YouTube shows fixes being done under the dash and some on here have said it can be fixed from the intake; although I don't see how that could be done. Do a search on the forrum and some info should come up. Good luck.

dr.lee.baugh 08-09-2012 08:34 AM

Re: Weird A/C problem?
 
Quote:

Originally Posted by remmy (Post 667656)
I researched more to find that these supposedly never break in the WK. only way to find out now without taking it apart is recharge the a/c. I'll pick up a kit in the morning.


There have certainly been a few members on here that have experienced this problem.


Honestly, I think you're wasting your money buying a re-charge kit - it shouldn't be low on refrigerant unless there is a leak in the system.

IMO spend the money you're going to pay for the re-charge kit and take it to a shop to get diagnosed properly.

remmy 08-09-2012 10:51 PM

I do not want to pay through the nose on this problem. It doesn't look like I need to disassemble the whole dash but I'd like a solid answer before I do exploring.

dr.lee.baugh 08-10-2012 08:48 AM

Re: Weird A/C problem?
 
Well, let us know how it goes. We'll certainly help when possible.

Good luck.

remmy 08-10-2012 11:28 AM

Prob won't get to it for another week but when I do I'll do a walk through

Galaxie500 08-14-2012 11:24 PM

Re: Weird A/C problem?
 
Quote:

Originally Posted by remmy (Post 667355)
Is there any particular reason why one side of my WK blows ice cold and the passenger side not so much? The Jeep has 95k on it and probably needs a refill(never done it, don't know how to). Anybody have this problem?

I found this on wkjeeps.com http://wkjeeps.com/tsb/tsb_wk_2400209.pdf
It may help you diagnose further. Look at Page2 under "MTC Repair Procedure" Step2 "Perform a Manual Door Calibration".
I am still trying to get the dealer to fix this problem below:
SYMPTOM/CONDITION:
Customer may complain that panel temperatures increase too rapidly when the temp knob is moved one or two detents from full cold while in manual mode. This service bulletin will provide the customer with smaller, more expected, panel temperature increases per detent move from the full cold temperature knob position.
MTC has been replaced but this problem still exist.:mad:

Moakley07 08-15-2012 07:36 AM

Re: Weird A/C problem?
 
Would a bad Blend Door Actuator also contribute to my sqeaking/squeeling issue?

Laredo2006 08-16-2012 08:53 PM

Re: Weird A/C problem?
 
I had exactly the same problem on my 2006 wk Laredo 4.7, (no cold air coming from passenger and back) did a diagnosis at the dealer for 90$ and 160$ for a recharge and it works perfectly now. They told me they added some colouring to see if it comes out from somewhere and that I'll have to bring it back to see will go soon...


All times are GMT -5. The time now is 05:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community