Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   information display gone mad whaen aftermarket stereo installed (http://www.jeepgarage.org/f77/information-display-gone-mad-whaen-aftermarket-stereo-installed-45969.html)

spritemad 08-12-2012 08:53 AM

information display gone mad whaen aftermarket stereo installed
 
Hi Guys - been looking around this site for a while and thought i'd ask if anyone can help with this, appologies if its in the wrong area ! I have a 2006 Grand Cherokee fitted with factory 6 disc cd changer/navigation unit. I fancied a change so got myself a chinese Radio/DVD/GPS/Bluetooth double din head unit, also got a harness connector and all went well with the install. However.... the information display in the instrument panel now refuses to display anything other than German !:confused: you can change the language to whatever you want and within 5 seconds it switches back to German, As I dont speek German this is not very helpfull :D can anyone suggest a reason for it or a fix for it ?

Thanks

Paul

SvenskaJeepGuy 08-12-2012 12:55 PM

Re: information display gone mad whaen aftermarket stereo installed
 
Quote:

Originally Posted by spritemad (Post 669233)
I fancied a change so got myself a chinese Radio/DVD/GPS/Bluetooth double din head unit


there is your problem right there, what made you think that would be a good idea? lol

robpp 08-12-2012 04:04 PM

Agree with matt

And


Is your wk an export model?

If so its prolly in the harness. IIRC even legit early PAC. harness had a Lang issue on export wk.


All times are GMT -5. The time now is 10:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community