Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Question about wires and cop boots (http://www.jeepgarage.org/f181/question-about-wires-and-cop-boots-46142.html)

Rooky 08-15-2012 11:28 AM

Question about wires and cop boots
 
I pulled the plugs in cylinder 1 to have a look and noticed when I took the coil off that there wasn't a distinct feel that the connection inside the boot was very good. Also the ceramic outside the cylinder has a brown ring right at the metal. The coil just lifted off with no resistance to indicate the plug and boot are making a good connection. Should I feel a click when pushing the coil back on like I do with the regular boots on the wires? It is an 05 GC 5.7L. All plugs were recently replaced before I bought it.

4.whoa 08-15-2012 12:36 PM

Re: Question about wires and cop boots
 
i thought the same when i got mine, however its normal. the coil only has a spring that keep pressure on the plug , no "snapping". the brown that you're mentioning, is it dirty(normal) or wet oil? the valve covers have "o" rings that seal the plug area, sometimes they seep.

Rooky 08-15-2012 06:24 PM

Re: Question about wires and cop boots
 
It's not oil or dirt, almost like a burn ring


All times are GMT -5. The time now is 05:21 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community