Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   low idle (http://www.jeepgarage.org/f107/low-idle-46171.html)

hummer recovery team 08-16-2012 09:06 AM

low idle
 
I have a 2006 jeep commander 4.7, and I recently changed the tps and iac and map sensors and yesterday i seafoamed and did my spark plugs, i plan to change the oil on saturday my idle would idle down real low and than bounce back up it would idle down too 500 than back up to 650 its always smooth, maybe egr? I used the stock plugs, any help is appreciated, I also disconnected the negative battery cable when I did the plugs could the computer be relearning?

doberman 08-16-2012 03:25 PM

Re: low idle
 
you should take it to the dealer so they can deal with it...

2012 Summit 08-16-2012 04:56 PM

Re: low idle
 
Quote:

Originally Posted by doberman (Post 671435)
you should take it to the dealer so they can deal with it...

Probably out of warranty?

hummer recovery team 08-16-2012 10:38 PM

Re: low idle
 
yep out of warranty

jerkylips 08-16-2012 10:48 PM

Something really similar happened to my wife's galant. Brought it back to the garage & he discovered one of his mechanics forgot to reset something having to do with relearning. He reset it & the car ran perfect - immediately. Sorry, I don't remember exactly what it was, was over a year ago. I think you're on the right track, though.

hummer recovery team 08-16-2012 11:42 PM

Re: low idle
 
thanks for the help, I may reset the computer

savvas 08-17-2012 01:39 AM

Re: low idle
 
Something similar happened to my old car. In the US it was known as an Isuzu Trooper, and it had the 3.5 V6 engine.

The idle control valve would get carboned up, and could result in bouncing idle as the ecu tried to keep things at the right speed. It was a simple case of undoing two screws, carefully removing the valve, cleaning the valve and the port on the throttle body with some carburettor cleaner and re-installing it.

I dont know whether your 4.7 has a similar setup or not, but it would be worth investigating.


All times are GMT -5. The time now is 04:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community