Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Export Grand Cherokee 2011+ (http://www.jeepgarage.org/f190/)
-   -   Electrical issues? (http://www.jeepgarage.org/f190/electrical-issues-46208.html)

Gribbs 08-17-2012 07:18 AM

Electrical issues?
 
Who has had electrical issues with their jeep grand Cherokee?

Here is a list of mine so far:
1. Reversing camera failed
2. Security system locked my children in the vehicle. But jeep can't replicate the fault
3. The ignition system shut down at 110kmh stranding us in the middle of nowhere. But jeep can't "replicate the fault".
4. Reversing camera failed again
5. The vehicle fails to start from time to time, requiring me to exit the vehicle, walk about 10m away, lock, unlock 3 times and then try again, and it will generally start then.

In really hoping this is not a sign of jeep quality.

Who else is having issues?

allypally 08-17-2012 03:31 PM

Re: Electrical issues?
 
Gribbs,
I have not heard of anyone in Oz having so much trouble with their WK2 as you are having. It certainly appears that you have a lemon.
Were you not taking them to court? What happened there?

I personally have only had 1 problem with the ignition where I stopped at a petrol pump and when hitting the stop button, all lights on dash lit up and chimes sounded. The car would not restart, I had to remove the button and use the key to get life back. Never happened again.

Gribbs 08-17-2012 03:44 PM

Still going through court, but I'm trying to decide if I want to get a replacement or a refund

ENFORCER 08-17-2012 04:44 PM

Re: Electrical issues?
 
I have had the starting issue, Alarm going off randomly & Radio going crazy.
All seem to have been fixed now via TSB. The ACC problem was caused by the dealer, so I do not call that a fault.
Honestly, if I had the problems you have had, I may ask for a refund. My reasoning is that you may end up with another problem and going through the whole process again may send you postal.

Mendo 08-17-2012 07:46 PM

Re: Electrical issues?
 
No issues

scarps 08-17-2012 09:19 PM

I've had the reversing camera not work 2wice. Put gear into reverse, screen goes black, no visual. Each time I fixed it by putting gear back into nuetral, then back into reverse, and it worked 2nd time. Thinking it's just the computer lagging. Hasn't happened in last 6 weeks, so not worried.
Not experienced any of the other faults you mentioned.
Sorry to hear you're not enjoying what should be a happy Jeep experience.


All times are GMT -5. The time now is 11:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community