Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Export Grand Cherokee 2011+ (http://www.jeepgarage.org/f190/)
-   -   I've broken down (http://www.jeepgarage.org/f190/ive-broken-down-47015.html)

GMWK2 09-03-2012 10:51 PM

I've broken down
 
Waiting for the quicklift.....

Engine warning light, electrical warning light, running rough, no power and burning smell. A drive belt???

Aghhhhhh.!!!!!!!!

allypally 09-03-2012 11:50 PM

Re: I've broken down
 
Sounds like a belt... smells like a belt?

AussieWK2 09-04-2012 12:17 AM

Re: I've broken down
 
Is it me or are these machines "hit and miss"?

I'm sure other forums for other cars are going through the same problems but does it seem to be an unusually higher ratio of our cars were built on a Monday or Friday? I think mine is a Wednesday build as I've had only minor / expected issues.

GM, I'm sure you've already actioned something but I'd be interested to see if you called Jeep Assist and what the outcome was?

GMWK2 09-04-2012 02:13 AM

Re: I've broken down
 
Yep, the main sepantine belt is goooonnnne....

Car is now at the dealer. Of course they don't have a spare serpantine belt so it has been ordered and they will have it tomorrow. They will then try and find the cause - maybe a seized pully?

And yes, I called Jeep Assist from the side of the road. I explained the issue and that I thought it was the drive belt but the women obvioulsy had a proceedure, wondered if it was the battery because the electrical warning light had come on. She asked me to get out of the car, lock and unlock the car 4 times (and pat my head and rub my tummy) presumably to try and reset the car.

Obvioulsy this didnt work so she arranged the quicklift truck which came in about 3/4 hr, and I had a nice sit in the sun while I waited.

Interesting that you cannot get the car in neutral without starting it, so the quicklift guy had to start it, posssibly doing more damage. Is that what the little N button behind the terrain response knob is for?

jefferson.oz 09-04-2012 02:24 AM

Re: I've broken down
 
Yep, sure is....

savvas 09-04-2012 07:25 AM

Re: I've broken down
 
So you got an electrical warning light? Was it the battery one?

There's a thread somewhere here that talks about there being no warning light if the drive belt breaks.

http://www.jeepgarage.org/f190/charging-system-light-40884.html

John47 09-04-2012 05:36 PM

Re: I've broken down
 
Quote:

Originally Posted by GMWK2 (Post 678909)
Yep, the main sepantine belt is goooonnnne....

Car is now at the dealer. Of course they don't have a spare serpantine belt so it has been ordered and they will have it tomorrow. They will then try and find the cause - maybe a seized pully?


Interesting that you cannot get the car in neutral without starting it, so the quicklift guy had to start it, posssibly doing more damage. Is that what the little N button behind the terrain response knob is for?

Likely a worthwhile exercise for us all to know how to get the thing in neutral in case of towing or whatever. Ours won't shut down unless it is in park. If it won't or can't be started I for one would be leafing through the manual.
Isn't there a shift lock access down beside the console?
I'm going to check it out and have a practice at it it anyway.

GMWK2 09-04-2012 06:12 PM

Re: I've broken down
 
Quote:

So you got an electrical warning light? Was it the battery one?
Looked up the warning light - it was the electronic throttle contol - page 170 of the owners manual. Two vertical bars with a lightning bolt. Discription matches - loss of power, rough idle.

Quote:

Likely a worthwhile exercise for us all to know how to get the thing in neutral in case of towing or whatever
And this - page 248.

GMWK2 09-04-2012 06:13 PM

Re: I've broken down
 
AGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH.

Just got a call from the dealer - 5 weeks for a new pully!


AGGGHGGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH

I've asked him to send me the part number and Ill see if I can source it myself.



AGGGGGGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH

GMWK2 09-04-2012 06:59 PM

Re: I've broken down
 
If anyone wants to help me out with a research project for the day, I need to source 2 parts for the dealer :

Part Numbers :

04593985AA Idler Pully
55038005AD Hose

I've flicked off a couple of emails to USA web sites to check delivery time, but if anyone can suggest a good place to order these parts I would be very grateful.

fix69er 09-04-2012 10:22 PM

Re: I've broken down
 
http://www.factorymoparparts.com/04593985aa.html

I have ordered others parts from factorymoparparts and got parts in 10 days. good luck.

GMWK2 09-04-2012 10:55 PM

Re: I've broken down
 
So after a round of cranky phone calls including to the (useless) customer service in Melbourne, I suggested to the dealer that they take the parts off a demonstrator or car in a yard somewhere.

So that's what they are going to do.

They need to find the cause and then will cannibalise one of their new cars that is waiting to be delivered. Sorry to whoever's car this was....


All times are GMT -5. The time now is 02:48 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community