Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Hello (http://www.jeepgarage.org/f107/hello-47352.html)

ptfour 09-11-2012 09:16 PM

Hello
 
I have 2011 grand cherokee anniversary edition with hemi 5.7. I've had the car to Dealer twice for loud banging noise from Park to Reverse Or Neutral. They installed spacer plate & it still does it. Now they tell me to wait for a flash on this problem. Anyone with a answer to this problem? Can I lemon law it since no repair can be done at this point?

AAAA 09-13-2012 08:22 AM

Re: Hello
 
Depends on your state. I think most states require 3 unsuccessful dealer service visits within a specified period of time.

armoredsaint 09-13-2012 08:25 AM

Re: Hello
 
have you checked the back for the dead hooker you tied up ;):D


eta: to be serious, when my jeep is cold in the morning and i move it to D or R immediately after starting up I get a little noise myself. plus i'm not sure if the tranny is slipping, but i feel the gear engagement on mine isn't that good, like a 1/4 sec delay before the gears mesh together?

found the TSB and looks like the dealer did what he's suppose to do - hopefully new program will fix it http://wk2jeeps.com/tsb/tsb_wk2_2101012.pdf


All times are GMT -5. The time now is 09:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community