Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   4WD LOW does not work, help! (http://www.jeepgarage.org/f181/4wd-low-does-not-work-help-47591.html)

kevinzhu 09-17-2012 06:59 PM

4WD LOW does not work, help!
 
Hi everybody, nice to meet you! Please help!
Emergency occurred on my 05 WK 4.7L! I doubt I broke my transfer case since i cannot enable 4WD Low! Please help!

I performed the shifting procedure from 4 High to 4 Low as below:
1. Shifted to "N".
2. Pulled T handle till info displayed 4 Low is enabled.
3. Accelerate by stepping gas paddle but no power is delivered only with engine growl.

Several days before once i shifted the transmission from "N" to "D" while the 4 Low was still enabled, was this action damaged the transfer case? Thank you!

JRsmoothee 09-17-2012 07:04 PM

Re: 4WD LOW does not work, help!
 
step #4 put transmission back into drive and accelerate (while 4 LO is enabled)

kevinzhu 09-17-2012 07:27 PM

Re: 4WD LOW does not work, help!
 
Thank you very much for the quick response!
I thought the vehicle can be moved with "N" under 4 Low mode...
I misunderstood the operation manual...

Madanio24 09-18-2012 06:44 PM

Re: 4WD LOW does not work, help!
 
Yea neutral basically means nothing is engaged on the engine.


All times are GMT -5. The time now is 09:36 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community