Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - ZJ (http://www.jeepgarage.org/f78/)
-   -   Huge Power steering problem!! Help!!! (http://www.jeepgarage.org/f78/huge-power-steering-problem-help-47711.html)

jamestaylor47 09-19-2012 10:52 PM

Huge Power steering problem!! Help!!!
 
Okay I've got a 1996 grand Cherokee limited with the 4.0 I6 and ever since I got it it's had a problem steering when the motor was idling. It would work like its supposed to if you revved up the engine quite a bit. But it finally got to the point where I lost all power steering unless I revved it up real high so I bought a new pump and switched it out and now I have no power steering at all NONE no matter if I rev it up at all. (the new one did come with te spot where the line connects straight to the pump and on the old one it had that sensor thing on it. I took my sensor off an put it on the new one. (p.s it's not the pump itself bc I thought at first maybe the new pump was bad so I took it back to oreileys and replaced the new one and still same problem. Plenty of fluids. No leaks that I can see. I did take the metal line off te front where the front and it shot out fluid. So that means its pumping right? Im thinking it might have something to do with the line connects maybe. But I'm not sure. Any ideas?

VistaCruiser 09-21-2012 01:16 PM

Re: Huge Power steering problem!! Help!!!
 
Air in the system? Pop the cap, see if it's foamy/bubbly. Low/high pressure lines hooked up proper? Rev it and start turning the steering wheel back and forth, lock to lock, until the system gets fully charged. HTH.

Sam

jamestaylor47 09-24-2012 12:48 AM

Turns out it was that friggin sensor. I pulled that off ran it straight to the pump. Runs like a champ now


All times are GMT -5. The time now is 10:30 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community