Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Fuel issue (http://www.jeepgarage.org/f203/fuel-issue-47926.html)

CheapJeep82 09-25-2012 04:20 PM

Fuel issue
 
Hello jeep garage.

I am just wondering if anyone has come across 'fuel trim bank 1 sensor'. Was on torque last night and noticed it wasn't working but bank 2 was.

Any input will be appreciated.

Cheers

Frango100 09-25-2012 07:45 PM

Re: Fuel issue
 
Heee, another Cheapjeep in the garage, welcome:thumbsup:
Is there any fault code set when doing the key dance? (ignition switch off/on 3 times and leave it in on at the third time. odometer will show the fault(s) or "Done" when all ok.)
Looks as an O2 sensor or wiring problem.

CheapJeep82 09-25-2012 09:59 PM

Re: Fuel issue
 
Yeah there was an MIL code which was P0420 catalyst bank 1 below threshold. The data we were getting was indicating that the 02 sensors bank 1 & 2 were producing the same voltage readings. The code only came up after the dealership tested the fuel rail pressure to see if the o'ring at the fuel pump was u/s.

We cleared the code but I haven't been able to take for a decent drive to see if it will come back on. Sometimes it takes a while for it to kick over, it's like an injecter is dribbling and flooding the chamber... I think this maybe related. And I'm not sure how to test fuel flow rate without a scanner.

Frango100 09-26-2012 05:41 AM

Re: Fuel issue
 
Are the voltage readings from the O2 sensors jumping up and down, or are they more stable? A good O2 sensor should have voltage readings which are not stable.
The fuel trim values (STFT and LTFT) are calculated by the PCM using the inputs from the O2 sensors.
STFT (short term fuel trim) are the immediate fuel trims done by the PCM, while the LTFT (long term fuel trim) reflect the fuel trims over a longer period of time. Are both values not working for bank 1?
Does the jeep have starting problems or driving problems that you took it to the dealer to test the fuel pressure?

CheapJeep82 09-26-2012 08:59 AM

Re: Fuel issue
 
Both LT and ST fuel trims are working. All 4 02 sensors working, varying voltages.
Jeep went to dealership cause it was stalling occasionally when idling. New o'ring on fuel pump sorted it. Just has a long crank time occasionally.

Frango100 09-26-2012 10:11 AM

Re: Fuel issue
 
But at your first post you where stating that the bank 1 sensor wasn't working. Did the dealer also change the fuel filter/pressure regulator? That one should keep the fuel pressure in the rail with the engine off, so that it will start up instandly.


All times are GMT -5. The time now is 02:42 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community