Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   P0717 and an MB Transmission (http://www.jeepgarage.org/f181/p0717-and-an-mb-transmission-48021.html)

Temerarius 09-27-2012 10:37 AM

P0717 and an MB Transmission
 
So, my 2009 JGC threw a P0717 error (goes into gimp mode and locks down the tranny).

It's a bad input speed sensor on the transmission.. no biggy.. UNLESS you have the Mercedes transmission (which my 3.7 does apparently) and not the 45RFE that most every other model has in it.

If it had the 45RFE, it would be a simple bolt to replace the sensor.

But, as it's the Merc, you have to drop the tranny and replace the entire assembly.

Part ran about $250 plus fluids and what not... grand total was about $800.

Ye been warned fellow 09 3.7 JCG owners...

2005JGC 09-28-2012 10:48 PM

Re: P0717 and an MB Transmission
 
you do NOT need to drop the trans, its the lead frame where the speed sensors are located, it mounts above the valve body, dropping the pan (easiest pan EVER), remove the guide bushing (the plug bushing) and drop the valve body. unsnap the lead frame, snap the new one in and reverse procedure.

stashgto 09-29-2012 11:39 PM

Re: P0717 and an MB Transmission
 
I did mine a few months ago like 2005 said there's no need to drop the trans.

BLKCRD 03-05-2013 10:32 AM

Re: P0717 and an MB Transmission
 
Hello guys,
My Jeep is having the same problem. I'm getting the same code P0717. Dealer recommended replacing the Electrohydraulic Unit. Did you chanage just the sensor or the whole unit? price is a lot different for each.


All times are GMT -5. The time now is 03:51 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community