Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   New to forum and need help with WK (http://www.jeepgarage.org/f181/new-to-forum-and-need-help-with-wk-48362.html)

Holykngt 10-04-2012 01:45 PM

New to forum and need help with WK
 
Hi, I have a 2005 JGC and I bought it when it was brand new and have replaced everything on it myself, never had it in any shop.
Anyways, I need some help to understand why the new ignition switch I bought will not work? I've had the electric problem where the dash lights/gauges click on and off along with the head lights and I figured I'd start with the ignition switch since that is what a lot of people suggest. Only problem is that the new one's (I've returned 2 of the switches and have replaced it with a total of 3 different new ones) and not one has worked at all. I end up having to put my old ignition switch back on in order to drive my jeep out of the garage. My local dealer told me that it costs 165 dollars to replace the ignition switch, and then an additional 65 per key I want to have linked to the ignition switch. I'm trying to find a way not to get robbed and instead only pay the 40 dollars for the ignition switch.
Now I've read a bunch on the subject but no one on any forum seems to have any problem simply replacing their ignition switch. Is there a code or trick that I'm missing? I've heard you have to click the key to the on position 3 separate times to program the key to the ignition switch. Any clues or tips? Thanks guys!

Chas 10-04-2012 02:43 PM

Re: New to forum and need help with WK
 
I just had the same issue so I am curious what the knowledgeable guys on here say. I ended up disconnecting my battery after it happened, let it chill, then hooked it up again and have had no issue, but I'd like to know this info if this happens to me again and I need to replace the ignition switch.

spyder873 10-04-2012 02:56 PM

Re: New to forum and need help with WK
 
we have had this issue in our commander for a few years. We finally tracked it down to a pinched wire at the base of the column , especially if you have had a remote start installed.

We tried the ignition switch as well with no luck.

some other places to look would be, the Big wire connection between the battery and the Firewall on the drivers side. , for this pull the connection apart a few times , then add some anti corrosive lube On them .

there is a Big connection right under that one . It needs the same as above.

That was on our commander , the spots may be slightly different on the WK . but take a look and see

RonRock 11-01-2012 09:13 AM

Re: New to forum and need help with WK
 
Thanks Spyder873, I'm dealing with the same issue. I'm considering swapping out the ignition switch also. I'll first take a look at the wiring points you mention.

But if I do end up replacing the ignition switch, is there an answer to the OP's question?


All times are GMT -5. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community