Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   08 Hemi idle drops too low intermittently & stalls (http://www.jeepgarage.org/f181/08-hemi-idle-drops-too-low-intermittently-and-stalls-48509.html)

bet_on_black 10-07-2012 03:44 PM

08 Hemi idle drops too low intermittently & stalls
 
Just got a new to me 08 Limited 5.7 and have done all the basics: all fluids, egr, map, tb cleaning, air filter. It runs great but the idle will drop every once in a while, even causing a stall when coasting down a hill once. Any ideas?

Thanks!

dmsfun 10-08-2012 12:19 PM

Re: 08 Hemi idle drops too low intermittently & stalls
 
Did you reset the ecu after all those items were replaced ? just unhook the battery neg terminal for a while to reset. Also check all the clamps on the intake to make sure there are no air leaks. When installing a replacement MAP, sometimes they are not tight fitting and can leak a bit of air. You can wrap the base where it installs with some teflon tape to tighten it up.

lboggs24 10-11-2012 07:14 PM

Re: 08 Hemi idle drops too low intermittently & stalls
 
dmsfun is correct. Unhook your negative on your batt and when you reconnect it, start the Jeep, let it idle for a min w/ the A/C off, then turn your A/C and let it idle for a min, then take it for a spin. That should reprogram your idle.

bet_on_black 10-19-2012 09:20 AM

Re: 08 Hemi idle drops too low intermittently & stalls
 
This did the trick, thanks!

bet_on_black 10-30-2012 09:22 PM

Re: 08 Hemi idle drops too low intermittently & stalls
 
It died again today... Now what?

Madanio24 10-30-2012 09:37 PM

Re: 08 Hemi idle drops too low intermittently & stalls
 
Mine used to do it. I believe it was the idle sensor in the throttle body.

brent 10-30-2012 09:43 PM

Re: 08 Hemi idle drops too low intermittently & stalls
 
My 07 had a software update. Don't recall which one. Also check the transmission fluid level. I still drop in RPMS once in and noticed it just today when I went from Drive to Park.

Here's my thread. http://www.jeepgarage.org/f5/more-id...ions-6876.html

I don't stall anymore after the software update. It does do a weird drop/bounce like it's about to stall but never has since the s/w.


All times are GMT -5. The time now is 07:22 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community