Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   No air!! (http://www.jeepgarage.org/f203/no-air-48839.html)

cheapjeep 10-14-2012 08:05 PM

No air!!
 
It was warm enough for air today and nothing! Fuse is good and so is the relay. Light comes on in dash but the compressor wont kick in. Can't believe I've had a catastrophic loss of freon because it was just working the other day.Anybody know what the pressure should be without the compressor running and also which two wires of the three wire pressure switch to jumper just to check the compressor? Also 100% sure the compressor is not locked up.

Frango100 10-15-2012 06:31 AM

Re: No air!!
 
Hi Dave, did you check both fuses? Fuse 21 on the junction block and fuse 21 in the PDC?
For checking the compressor, you could jumper the points 30-87 of the compressor relay in the PDC.
The pressure switch connector point 2 is the 5V supply and point 3 is the reference pressure signal. Not sure if you can just simply jumper these two.

cheapjeep 10-15-2012 06:38 PM

Re: No air!!
 
Thanks Frank I swapped relays with the horn so I know it's ok. Didn't know about the fuse under the dash though. I'll check that tomorrow as well as check for power at the clutch. Unless I somehow developed a major leak in the last few days and emptied the system I'm thinking(hoping) the trouble is in the pressure switch or the clutch coil or even better the fuse I missed. I"ll know more once I break out the meter.

cheapjeep 10-19-2012 10:00 PM

Re: No air!!
 
Well figured out how to jumper out the clutch at the relay socket since the newer wj has no low pressure switch.Terminal 30 to terminal 87 in the clutch relay socket will bypass the PCM and the pressure transducer. Got the compressor to run and got my gauges on to find out its totally empty. Well on a positive not at least the wiring is ok and working like it should.Bad news is there is a major leaked that emptied the system.Praying it's not the evap core!!!

Frango100 10-19-2012 10:19 PM

Re: No air!!
 
There are indeed some small but important differences in the airco systems between older and newer WJs. The older WJs use the low pressure switch to prevent freezing of the EVAP core, while the newer WJs have a temperature sensor mounted in the EVAP core to do the same. There is still a pressure transducer, which sends pressure information to the PCM for control reasons.
Will you take it to a specialist Dave, to look for the leak?

cheapjeep 10-20-2012 04:41 PM

Re: No air!!
 
Yeah buddy I'm gonna let the pros handle this one because I don't see any obvious signs of a leak yet .

01grand 10-24-2012 10:09 AM

Re: No air!!
 
You can always get a can of UV dye at the parts store and see if you can find the leak yourself. If the system is totally depressurized you could do the repair yourself and then take it to a shop for a proper vacuum and refrigerant/oil recharge. That sucks that you suddenly developed a major leak. I have to figure out what's wrong with the cruiser AC as I have the same problem there.

cheapjeep 10-24-2012 08:43 PM

Re: No air!!
 
You know buddy I have a nagging feeling I may have caused this myself. I know that bottom mesh I put in there lays pretty hard against the bottom of the condenser. I didn't think anything of it at the time but now I'm starting to wonder if it could have rubbed a hole in the thing. Gonna have to take a close look there.

01grand 10-25-2012 09:02 AM

Re: No air!!
 
Yikes that would suck! The unintended consequences of modding haha. Not sure if the 04 is different but I just checked rock auto and they had a spectra condenser for $90 if that turns out to be the problem. Good luck with it!


All times are GMT -5. The time now is 03:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community