Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Engine problem? (http://www.jeepgarage.org/f107/engine-problem-49009.html)

zar787 10-18-2012 10:26 AM

Engine problem?
 
Hi All,

This is my first ever problem with my Grand Cherokee Limited. Had it for around 7 months with 29000 km mileage. The problem started one afternoon, wanted to go to work so I turned on the engine. It was able to start normally for like 2 seconds then it went dead. The same thing happened multiple times. Decided not to go to work. Later in the evening tried to turn on the engine, it won't start up at all this time. The next morning when the towing truck came, I tried again to start the engine, this time it worked but with the CEL turned on.

At the workshop, they tried to diagnose the problem but their computer could not recognise my car's ID or something like that. Left my car for around 1 week. They then called me up telling me to pick up my car saying that they changed the PCN(?) and re-programmed everything. They said that they've tested it and no problems seemed to emerge. I then happily brought back my Jeep.

Later in the evening however, the engine started having problems. The engine sounded like it wanted to die and the CEL comes up but before it does die, it goes back alive. And this repeats. The pointer in the RPM meter goes up and down. The engine sounds like its about to break down.

Took some videos to show what I'm talking about as frankly I know nothing about cars. One video is linked below (the other is still uploading). Anyone have any ideas what may be wrong with my car?



All times are GMT -5. The time now is 09:52 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community