Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Dash lights on but no codes pull up?? (http://www.jeepgarage.org/f181/dash-lights-on-but-no-codes-pull-up-49347.html)

readingbabelfish 10-24-2012 08:48 PM

Dash lights on but no codes pull up??
 
Hi all, my wifes 2007 laredo 3.7 wk has the esp/bas and tcs lights illuminated on the dash. It drives just fine but I'm wondering what these lights are on for. I have Quadratrac I, full time 4wd, does that system still work with these lights on? I plugged in my code scanner, and did the key dance, but no codes come up. I looked at the speed sensors from underneath the jeep and they all look just fine. I put a lift on with bigger tires about 1.5 years ago. I never calibrated for the bigger tires either so my speedo has been off since then. I called the dealership and they want like 90 bucks just to diagnose the problems. What do you guys think I should do and does anyone know what may be the problem? Thanks all!

SvenskaJeepGuy 10-24-2012 09:06 PM

Re: Dash lights on but no codes pull up??
 
take it to a parts store and use their code reader, sometimes certain readers dont work

readingbabelfish 10-25-2012 04:48 PM

Re: Dash lights on but no codes pull up??
 
Well, that didn't work either. I took it to Autozone and Oriellys and still no codes available. Stupid how my dash has 3 lights on but no codes... I'm sorry but that is rediculous... Why the hell should anyone buy a scanner if it only pulls up 1% of the codes anyway? I took off the tires and looked at the sensors, all look fine. The WK has less than 40k miles on it.... there is no way there should be all these problems unless its something with the lift kit, which has been on for 1.5 years with no problems till now. The steering tracks straight... So I guess I'm stuck going to the dealership so they can use their exclusive tool to get the exclusive codes. What a scam! I will post what the problems were once I have it scanned. I disconnected the battery and let it sit to no avail. If anyone has any suggestions I would certainly welcome them. Thanks!

Madanio24 10-25-2012 09:43 PM

Re: Dash lights on but no codes pull up??
 
My one scanner and autozones didn't pick up codes that my hypertech could. I picked up codes when the abs, electric brake and traction control lights were on. It was a wheel speed sensor.


All times are GMT -5. The time now is 01:25 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community