Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   coolant issue (http://www.jeepgarage.org/f5/coolant-issue-49404.html)

05WK4.7 10-26-2012 05:33 AM

coolant issue
 
ok so last decenber my 05 WK had some major engine problems (warped heads). so me and a buddy decided to do the wokr ourselves. now its been almost a year and there have been no fluids in the engine such as coolant and oil...now i got the oil and filter and new spark plugs but as far as coolant can i put in prestone 50/50 or do i need to go to the dealer and get the ""FACTORY COOLANT""...im not quite sure and i dont want to put the wrong coolant in. thank you

Madanio24 10-26-2012 09:30 AM

Re: coolant issue
 
They say you are supposed to buy the factory coolant. but after i changed my water pump/thermostat and did i flush i put in some coolant full-strength diluted by me. Says on the antifreeze its good for any color antifreeze normally used in a car and good for any brand. This was a year and a half ago and works great. Factory coolant so expensive

SvenskaJeepGuy 10-26-2012 12:38 PM

Re: coolant issue
 
on the 4.7 you have to use the factory HOAT coolant blended with distilled water

Madanio24 10-26-2012 12:49 PM

Re: coolant issue
 
Quote:

Originally Posted by SvenskaJeepGuy (Post 703078)
on the 4.7 you have to use the factory HOAT coolant blended with distilled water

Do you know why this is?

SvenskaJeepGuy 10-26-2012 03:23 PM

Re: coolant issue
 
Quote:

Originally Posted by Madanio24 (Post 703082)
Do you know why this is?

because not using HOAT can destroy your water pump and damage your engine

SvenskaJeepGuy 10-26-2012 03:24 PM

Re: coolant issue
 
mixing prestone with the hoat in your engine can cause the coolant to form a gel and clog the system. if they are mixed you will need to flush the system

Madanio24 10-26-2012 03:38 PM

Re: coolant issue
 
On the 3.7 do you have to use this type. I did a complete flush and coolants been fine for over a year.

SvenskaJeepGuy 10-26-2012 04:25 PM

Re: coolant issue
 
Im pretty sure all mopars require it. It takes a while for it to eat away at the plastic parts in the water pump.

05WK4.7 10-26-2012 08:04 PM

Re: coolant issue
 
would it be bad to use just hose water?

SvenskaJeepGuy 10-26-2012 08:12 PM

Re: coolant issue
 
Quote:

Originally Posted by 05WK4.7 (Post 703257)
would it be bad to use just hose water?

yes, hose water is not pure. just buy a few gallons of distilled water, it is dirt cheap

05WK4.7 10-26-2012 08:55 PM

Re: coolant issue
 
i can run straight distilled water instead?

05WK4.7 10-26-2012 09:15 PM

Re: coolant issue
 
so ur saying i can run straight distilled water or prestone with distilled water? i read that if u dont use HOAT it can ruin the plastic impellar...but i think my water pump came with a metal impellar on it so would it make a difference?


All times are GMT -5. The time now is 10:41 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community