Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (
-   Suspension/Brakes/Wheels/Tires (
-   -   Finally lifted, couple issues. (

cmckenna1990 10-28-2012 09:12 PM

Finally lifted, couple issues.
I finally installed my OME HD lift :) Ill finally do a build thread when i got more time.. BUT, after the lift... i my ABS, ESP BAS, and Traction control lights are stuck on.. Any idea where my issue could be with out knowing much more at this time? I had the entire front end apart short of the lower ball joint/control arm, everything else was torn apart :)

ps, i loved every minute of the lift even when it got frustrating!

paroxysym 10-31-2012 06:15 AM

Re: Finally lifted, couple issues.
did you hit a sensor installing the lift? disconnect anything? i believe on one of the other forums a guy hit his ABS sensor in the front wheel well and had the same problem as you.

cmckenna1990 10-31-2012 03:15 PM

Re: Finally lifted, couple issues.
yeah turns out i hooked up the scanner finally and i have a front driver wheel sensor fault.. but do you think that esp bas light is affected by that as well?

paroxysym 10-31-2012 03:18 PM

Re: Finally lifted, couple issues.
yes i do... id say look on another forum for the exact thread- but that sensor will trip the ESP BAS light as well.

cmckenna1990 10-31-2012 03:22 PM

Re: Finally lifted, couple issues.
awesome.. fairly simple fix, thank you sir!

All times are GMT -5. The time now is 05:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community