Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f183/)
-   -   Help!!! (http://www.jeepgarage.org/f183/help-49737.html)

jeep0714 11-02-2012 12:31 AM

Help!!!
 
I have a 2006 Jeep Grand Cherokee Limited V8 5.7L Hemi and i have a muffler on it and took off the back resonator. It runs great. However sometimes on random start ups when i go to turn it on it doesnt always start smoothly. Usually its fine but sometimes i have to do the key turn 2 twice before it starts all the way. Is this normal or does something need to be done? Only sometimes usually when its hot out it doesnt always ive noticed. And also it never starts the same way everytime sometimes its louder than others and others its softer. Why is this? Please comment any advice.

06grand 11-02-2012 08:38 AM

Re: Help!!!
 
when was the last time you did any maintenance on it, ie. plugs, tb clean etc. also any symptoms while driving

Relwarc 11-02-2012 08:47 AM

Re: Help!!!
 
where are you located?

Sometimes the cold will do that. it's a 6 year old hemi....

jeep0714 11-02-2012 12:12 PM

Re: Help!!!
 
I live in Northern CA. Its not to cold yet been about 65-70 lately.
It only happens sometimes not very often. Is there something that might need cleaned or cleaned out from dirt or something?

jeep0714 11-02-2012 12:12 PM

Re: Help!!!
 
Driving if fine and smooth still.

06grand 11-02-2012 01:29 PM

Re: Help!!!
 
I dont know what it could be, Im sure someone more savvy than me can narrow it down, but if it were me and I knew it hadnt been done in a while, I would start by checking plugs, cleaning the throttle body, sea-foam it, check PCV, EGR etc..


All times are GMT -5. The time now is 01:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community