Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Cherokee-SJ and XJ (http://www.jeepgarage.org/f19/)
-   -   I need help!!!! (http://www.jeepgarage.org/f19/i-need-help-49890.html)

jeeptuff328 11-05-2012 08:56 AM

I need help!!!!
 
I know its probably somethin majorly simple but im a virgin jeep owner. i have a 99 cherokee sport. i cant seem to figure out why it will start and idle fine yet when u take off it starts to try and die or it just outright dies. start it up and it goes right back to idling just fine. Like its losing fire on take off or starvin for fuel. What is this caused by???? i would drive it to town to get codes but its a 20 mile drive and it wont go 1/4 mile without dyin

Frango100 11-05-2012 11:59 AM

Re: I need help!!!!
 
So the key dance doesn't work on your jeep?

jeeptuff328 11-05-2012 01:52 PM

Re: I need help!!!!
 
OK key dance did not work. Nuthin popped up but odometer reading. Pulled positive terminal off to try and reset it. Now the check engine light stays on but will flicker off and when. It does that it dies. Heading to the parts store now to have codes checked. So far its made it the 20 miles and only tried to die once but picked back up without completely stallin.

jeeptuff328 11-05-2012 02:10 PM

Re: I need help!!!!
 
OK had codes read. It is the tps!!!! Thank u anyone and everyone who helped me with problem.....now I can get back to workin on makin it purdy!!!!!

jeeptuff328 11-05-2012 02:52 PM

Re: I need help!!!!
 
Put the new one on and now its goin loopy again. Way worse than this mornin. I don't know what to do. Back at auto parts store now. Gonna have it checked again to see what it says now.

jeeptuff328 11-05-2012 03:30 PM

Re: I need help!!!!
 
And now it won't start and gauges aren't working.

jeeptuff328 11-05-2012 03:33 PM

Re: I need help!!!!
 
The air blows the lights come on. But gauges aren't workin and it ain't startin

Frango100 11-05-2012 03:49 PM

Re: I need help!!!!
 
Do you remember the error codes that they pulled?
Regarding the TPS, if its a non OEM part, it can give all kind of strange behaviour.
Did you try a reset again by disconnecting the negative battery terminal for some minutes?
I remember a case that they found a cable loom at the aft side of the cylinder head which was shaved through. Have a quick look for any abnormalities at the wiring.

jeeptuff328 11-05-2012 04:19 PM

Re: I need help!!!!
 
Yes reset he batt
Still nuthin. Trying it again now. Can't figure it out.

Frango100 11-05-2012 05:29 PM

Re: I need help!!!!
 
So what was the error code(s)? Only TPS?
Also the gauges get their info from the PCM, so could have to do with a wire problem.
As mentioned before, check the cable loom which goes behind the head, chaving is known to cause problems there .

jeeptuff328 11-05-2012 07:06 PM

Re: I need help!!!!
 
Come to find out there is a short somewhere in the huge bundle of wires goin to the computer thing. so u were correct on the wires but i had no clue what loom u were talkin about. so a friend had showed up to help since i was stranded in town with the baby and he got to movin wires. my husband decided to attepmt starting it one more time before towin it home and it started right up. they went to messin with wires again and it died. gonna mess around with it tommorow and try to pin point the wire causing the problem. i kept reverting to what u told me and they began tryin to pin point in the parkin lot but all i wanted to do was go home.

jeeptuff328 11-05-2012 07:08 PM

Re: I need help!!!!
 
When the check engine light goes off it starts to stall. but as long as the light is on it runs just fine. crazy but its gonna stay that way till i can get further in detail with it. it doesnt get driven other than to play or pull the boat so its gonna sit!


All times are GMT -5. The time now is 04:49 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community